View Issue Details

IDProjectCategoryView StatusLast Update
0001611OpenMPTGeneralpublic2022-07-03 18:00
ReporterPP0815 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version7
Product VersionOpenMPT 1.30.05.00 / libopenmpt 0.6.4 (current stable) 
Target VersionOpenMPT 1.30.06.00 / libopenmpt 0.6.5 (upcoming stable)Fixed in VersionOpenMPT 1.30.06.00 / libopenmpt 0.6.5 (upcoming stable) 
Summary0001611: New (IMO false) behaviour when selecting in sampleeditor (zoomed in)
Description

This might be what another user ment here https://bugs.openmpt.org/view.php?id=1581 but because I'm not really sure what he ment and the issue is still present I open this bug report (again).

I updated from
1.30.00.18-r13815 (32bit) Windows7
to
1.30.05.01-r17510

and realized a strange behaviour when selecting while zoomed into a sample.

Steps To Reproduce

Step1: zoom into the sample
Step2: start selection (leftclick hold & move mouse to the right). Keep the left button pressed for all the other steps.
Step3: move the scrollwheel 1 or more ticks towards you (do not move the mouse)
Step4: move the mouse

Old (and IMO correct) behaviour:
On Step3 the window scrolls to the right. The selection end won't move with this
On Step4 the selection end jumps to the cursor position

New behaviour:
On Step3 it's the same as the old behaviour
On step4 the selection end won't jump to the cursor position. It moves, but there is a gap between the selection end and the cursor position

TagsNo tags attached.
Has the bug occurred in previous versions?at least not in 1.30.00.18-r12815
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2022-07-03 14:17

administrator   ~0005243

I took me a bit to figure out what you mean, the important part is that the zoom factor is negative (1:x) and not positive (x:1).

It's not really related, but bugs are caused by the new timeline code and related improvements to the sample editor, but the root cause is completely different.

Saga Musix

Saga Musix

2022-07-03 14:40

administrator   ~0005244

Should be fixed in r17638. You can download the new build from https://builds.openmpt.org/builds/ in a few hours, or set the update channel to "Next" instead of "Release" in OpenMPT to get the bugfix.

PP0815

PP0815

2022-07-03 17:56

reporter   ~0005245

Thanks. It's working.

Issue History

Date Modified Username Field Change
2022-07-03 14:01 PP0815 New Issue
2022-07-03 14:03 PP0815 Has the bug occurred in previous versions? no => at least not in 1.30.00.18-r12815
2022-07-03 14:17 Saga Musix Note Added: 0005243
2022-07-03 14:17 Saga Musix Assigned To => Saga Musix
2022-07-03 14:17 Saga Musix Status new => assigned
2022-07-03 14:40 Saga Musix Note Added: 0005244
2022-07-03 14:40 Saga Musix Status assigned => feedback
2022-07-03 14:40 Saga Musix Product Version => OpenMPT 1.30.05.00 / libopenmpt 0.6.4 (current stable)
2022-07-03 14:40 Saga Musix Fixed in Version => OpenMPT 1.30.06.00 / libopenmpt 0.6.5 (upcoming stable)
2022-07-03 14:40 Saga Musix Target Version => OpenMPT 1.30.06.00 / libopenmpt 0.6.5 (upcoming stable)
2022-07-03 17:56 PP0815 Note Added: 0005245
2022-07-03 17:56 PP0815 Status feedback => assigned
2022-07-03 18:00 Saga Musix Status assigned => resolved
2022-07-03 18:00 Saga Musix Resolution open => fixed