View Issue Details

IDProjectCategoryView StatusLast Update
0001598OpenMPTUser Interfacepublic2022-05-21 12:12
Reportera11cf0 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target VersionOpenMPT 1.30.05.00 / libopenmpt 0.6.4 (current stable)Fixed in VersionOpenMPT 1.30.05.00 / libopenmpt 0.6.4 (current stable) 
Summary0001598: Go to previous/next entry commands don't work together with selection
Description

Unlike all other navigation actions, the next/previous entry in column shortcuts currently can't be combined with the selection key. This can actually be useful, e. g. together with the select event action, esp. when working non-visually.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2022-05-19 13:10

administrator   ~0005182

One problem here is that selections cannot span multiple patterns. The go to previous/next shortcuts can jump to a previous or future pattern if required. So when this is the case, should the selection 1) just not be made or 2) stop at the start or end of the current pattern?

a11cf0

a11cf0

2022-05-19 14:06

reporter   ~0005183

I think it is more logical to just stop at the last entry in the current pattern, since there are no more entries to select anyway.

Saga Musix

Saga Musix

2022-05-20 20:07

administrator   ~0005185

Implemented in r17350.

a11cf0

a11cf0

2022-05-21 12:12

reporter   ~0005186

Everything is working now. Thanks.

Issue History

Date Modified Username Field Change
2022-05-19 12:18 a11cf0 New Issue
2022-05-19 13:10 Saga Musix Note Added: 0005182
2022-05-19 14:06 a11cf0 Note Added: 0005183
2022-05-20 19:01 Saga Musix Assigned To => Saga Musix
2022-05-20 19:01 Saga Musix Status new => assigned
2022-05-20 19:01 Saga Musix Target Version => OpenMPT 1.30.05.00 / libopenmpt 0.6.4 (current stable)
2022-05-20 20:07 Saga Musix Note Added: 0005185
2022-05-20 20:07 Saga Musix Fixed in Version => OpenMPT 1.30.05.00 / libopenmpt 0.6.4 (current stable)
2022-05-21 12:12 a11cf0 Note Added: 0005186
2022-05-21 12:12 Saga Musix Status assigned => resolved
2022-05-21 12:12 Saga Musix Resolution open => fixed