View Issue Details

IDProjectCategoryView StatusLast Update
0001544OpenMPTUser Interfacepublic2022-01-09 15:15
ReporterLachesis Assigned ToSaga Musix  
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.30.01.00 / libopenmpt 0.6.0 (current stable) 
Target VersionOpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable)Fixed in VersionOpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable) 
Summary0001544: Sample sustain loop fields are greyed out for Digital Symphony modules.
Description

Digital Symphony sample loops are loaded as sustain loops, but the sustain loop fields are not directly editable. The sustain loop arrows in the sample display are editable, and converting to IT allows editing the fields, so this is mainly a cosmetic annoyance.

Steps To Reproduce

Load the attached module and switch to the sample editor. The sustain loop fields can not be edited.

Additional Information

The attached module was created this awful thing and tested in the Digital Symphony demo, since a working save-enabled copy of Digital Symphony is apparently very rare.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0001456 new Rethink mod conversion 

Activities

Lachesis

Lachesis

2022-01-09 03:41

reporter  

plastic.dsym.zip (6,363 bytes)
image.png (20,698 bytes)   
image.png (20,698 bytes)   
Saga Musix

Saga Musix

2022-01-09 12:49

administrator   ~0004978

Yeah, this is an issue with various imported formats when the imported feature is strictly not part of the feature set of the format they were converted to. This essentially ties into 0001456 where I want to solve this whole importing mess in a better way, alas in a non-trivial way... so maybe just unlocking those edit fields when they are in fact being used would be a good temporary measure.

Saga Musix

Saga Musix

2022-01-09 15:15

administrator   ~0004983

Workaround added in r16479.

Issue History

Date Modified Username Field Change
2022-01-09 03:41 Lachesis New Issue
2022-01-09 03:41 Lachesis File Added: plastic.dsym.zip
2022-01-09 03:41 Lachesis File Added: image.png
2022-01-09 12:49 Saga Musix Note Added: 0004978
2022-01-09 13:31 Saga Musix Relationship added related to 0001456
2022-01-09 15:15 Saga Musix Note Added: 0004983
2022-01-09 15:15 Saga Musix Assigned To => Saga Musix
2022-01-09 15:15 Saga Musix Status new => assigned
2022-01-09 15:15 Saga Musix Status assigned => resolved
2022-01-09 15:15 Saga Musix Resolution open => fixed
2022-01-09 15:15 Saga Musix Fixed in Version => OpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable)
2022-01-09 15:15 Saga Musix Target Version => OpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable)