View Issue Details

IDProjectCategoryView StatusLast Update
0001535OpenMPTUser Interfacepublic2021-12-23 19:30
Reportercs127 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.30.01.00 / libopenmpt 0.6.0 (current stable) 
Target VersionOpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable)Fixed in VersionOpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable) 
Summary0001535: Command slider range breaks when changing to/from an expandable command
Description

In the Note Properties window, if you change a command that can be expanded with # to another command (or vice versa), the parameter slider shows an incorrect range until the Note Properties window is closed and reopened.

Steps To Reproduce
  1. Open the note properties window on any cell.
  2. Use the drop down menu to change the command to a finetune command. If the command is already a finetune command, change it to any other command.
  3. The parameter slider will show the parameter in an incorrect range, until the note properties window is closed and reopened.
TagsNo tags attached.
Has the bug occurred in previous versions?Yes (e.g. with Offset command)
Tested code revision (in case you know it)16290

Activities

cs127

cs127

2021-12-23 18:55

reporter  

to_finetune.png (20,163 bytes)   
to_finetune.png (20,163 bytes)   
from_finetune.png (22,273 bytes)   
from_finetune.png (22,273 bytes)   
Saga Musix

Saga Musix

2021-12-23 19:19

administrator   ~0004960

This affects several "expandable" commands (commands that can be combined with #).

Saga Musix

Saga Musix

2021-12-23 19:30

administrator   ~0004962

Fixed in r16313.

Issue History

Date Modified Username Field Change
2021-12-23 18:55 cs127 New Issue
2021-12-23 18:55 cs127 File Added: to_finetune.png
2021-12-23 18:55 cs127 File Added: from_finetune.png
2021-12-23 18:57 cs127 Description Updated
2021-12-23 19:19 Saga Musix Summary Command slider range breaks when changing the command from/to a 1.30 finetune command. => Command slider range breaks when changing to/from an expandable command
2021-12-23 19:19 Saga Musix Note Added: 0004960
2021-12-23 19:19 Saga Musix Assigned To => Saga Musix
2021-12-23 19:19 Saga Musix Status new => assigned
2021-12-23 19:20 Saga Musix Target Version => OpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable)
2021-12-23 19:20 Saga Musix Has the bug occurred in previous versions? No, because the affected feature itself didn't exist. => Yes (e.g. with Offset command)
2021-12-23 19:26 cs127 Description Updated
2021-12-23 19:30 Saga Musix Note Added: 0004962
2021-12-23 19:30 Saga Musix Status assigned => resolved
2021-12-23 19:30 Saga Musix Resolution open => fixed
2021-12-23 19:30 Saga Musix Fixed in Version => OpenMPT 1.30.02.00 / libopenmpt 0.6.1 (upcoming stable)