View Issue Details

IDProjectCategoryView StatusLast Update
0001504OpenMPTFile Format Supportpublic2021-09-12 22:47
ReporterStarWolf3000 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform64-bitOSWindowsOS Version8.1
Product VersionOpenMPT 1.29.12.00 / libopenmpt 0.5.11 (upgrade first) 
Target VersionOpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable)Fixed in VersionOpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable) 
Summary0001504: First DLS instrument region is not imported
Description

OpenMPT 1.29.12.00 seems to have introduced some broken behavior on how some imported instruments in the higher patch numbers from SF2/DLS are handled.

Just playing back the same instruments in both 1.29.11.00 and 1.29.12.00 doesn't play the same samples, even regions, of the instruments, and even loads some "garbage" in the newer version (see attached pictures).

Samples load correctly in 1.29.11.00.

Steps To Reproduce

1) Use 1.29.12.00

2) Create empty module or load one

3) "Import" one of the shown instruments from GM.DLS (see one of the pictures which one are affected)

4) Look in the Sample tab and/or play back the selected instrument/sample

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Activities

StarWolf3000

StarWolf3000

2021-09-11 14:05

reporter  

ompt_1291100_samples.png (85,200 bytes)   
ompt_1291100_samples.png (85,200 bytes)   
ompt_1291200_samples.png (85,356 bytes)   
ompt_1291200_samples.png (85,356 bytes)   
StarWolf3000

StarWolf3000

2021-09-11 14:14

reporter   ~0004861

Might be related to the changes introduced in 0001457

Saga Musix

Saga Musix

2021-09-11 22:54

administrator   ~0004864

Instead of just taking the first matching region, that change made OpenMPT instead consider the smallest (most specific) region covering the requested key range. In those instruments, there is a bogus 1-key region spanning just the lowest note, so that is chosen. I guess I'll have to finetune that algorithm a bit more.

Saga Musix

Saga Musix

2021-09-12 17:54

administrator   ~0004865

Upon closer inspection, it seems to be unrelated to that, and it looks more like something in the importing of instrument regions broke when adding support for more than 128 regions per instrument. Every DLS instrument is missing its first region and has a bogus last region. Those instruments you mentioned only have one region, so you only end up with that bogus region.

Saga Musix

Saga Musix

2021-09-12 22:46

administrator   ~0004866

Should be fixed in r15678.

Issue History

Date Modified Username Field Change
2021-09-11 14:05 StarWolf3000 New Issue
2021-09-11 14:05 StarWolf3000 File Added: ompt_1291100_samples.png
2021-09-11 14:05 StarWolf3000 File Added: ompt_1291200_samples.png
2021-09-11 14:13 StarWolf3000 Relationship added related to 0001457
2021-09-11 14:14 StarWolf3000 Note Added: 0004861
2021-09-11 22:54 Saga Musix Note Added: 0004864
2021-09-11 22:54 Saga Musix Assigned To => Saga Musix
2021-09-11 22:54 Saga Musix Status new => assigned
2021-09-12 17:54 Saga Musix Note Added: 0004865
2021-09-12 18:01 Saga Musix Target Version => OpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable)
2021-09-12 18:01 Saga Musix Summary [SF2/DLS] Some instrument samples and regions broken in 1.29.12.00, working in 1.29.11.00 => First DLS instrument region is not imported
2021-09-12 18:01 Saga Musix Has the bug occurred in previous versions? No => Since 1.29.11.00
2021-09-12 18:02 Saga Musix Has the bug occurred in previous versions? Since 1.29.11.00 => No
2021-09-12 22:43 Saga Musix Relationship deleted related to 0001457
2021-09-12 22:46 Saga Musix Note Added: 0004866
2021-09-12 22:47 Saga Musix Status assigned => resolved
2021-09-12 22:47 Saga Musix Resolution open => fixed
2021-09-12 22:47 Saga Musix Fixed in Version => OpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable)