View Issue Details

IDProjectCategoryView StatusLast Update
0001498OpenMPTUser Interfacepublic2021-09-13 14:27
Reportera11cf0 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target VersionOpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable)Fixed in VersionOpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable) 
Summary0001498: Strange behavior of the treeview sample browser when looking inside modules
Description

When browsing module contents using the treeview I've noticed the following:
The .. item disappears, so the only way of going to the parent directory would be pressing backspace, but backspace doesn't do this. Instead, it moves up one more level.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-09-01 17:35

administrator   ~0004854

While it might not be obvious and certainly is not optimal, you can hit Return twice on the item that names the module in the lower part of the tree view, which first opens a folder browser opening the folder containing that module, and then selects that folder. That's how you can get out of that folder again. Backspace is tied to doing the same thing as the ".." item in the upper part of the tree view does, and as that part still points to the containing folder, backspace goes one folder up.

Saga Musix

Saga Musix

2021-09-13 11:50

administrator   ~0004867

r15680 adds a context menu item to the first item in the instrument browser to close it, and backspace now also goes back to the containing folder (both only applies in the lower half of the tree view, where the individual samples and instruments are listed).

a11cf0

a11cf0

2021-09-13 13:52

reporter   ~0004868

There's one more small thing. Maybe this is intended, but when backspacing to the containing folder the cursor position is not restored. Everything is great otherwise. Thanks for fixing keyboard accessibility issues. This is one
of the things that make this project really outstanding.

Saga Musix

Saga Musix

2021-09-13 14:27

administrator   ~0004869

Right, this should be fixed as of r15682.

Issue History

Date Modified Username Field Change
2021-09-01 13:06 a11cf0 New Issue
2021-09-01 17:35 Saga Musix Note Added: 0004854
2021-09-13 11:50 Saga Musix Note Added: 0004867
2021-09-13 11:50 Saga Musix Assigned To => Saga Musix
2021-09-13 11:50 Saga Musix Status new => assigned
2021-09-13 11:50 Saga Musix Assigned To Saga Musix =>
2021-09-13 11:50 Saga Musix Assigned To => Saga Musix
2021-09-13 11:50 Saga Musix Status assigned => resolved
2021-09-13 11:50 Saga Musix Resolution open => fixed
2021-09-13 11:50 Saga Musix Fixed in Version => OpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable)
2021-09-13 11:50 Saga Musix Target Version => OpenMPT 1.29.13.00 / libopenmpt 0.5.12 (current stable)
2021-09-13 13:52 a11cf0 Status resolved => feedback
2021-09-13 13:52 a11cf0 Resolution fixed => reopened
2021-09-13 13:52 a11cf0 Note Added: 0004868
2021-09-13 14:27 Saga Musix Note Added: 0004869
2021-09-13 14:27 Saga Musix Status feedback => resolved
2021-09-13 14:27 Saga Musix Resolution reopened => fixed