View Issue Details

IDProjectCategoryView StatusLast Update
0001491OpenMPTFeature Requestpublic2021-09-21 19:22
Reportera11cf0 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0001491: Ability to add instruments from the MIDI library with the keyboard
Description

Currently it's possible to load instruments from the midi library only by dragging and dropping them. It would be good to be able to do this via a keyboard shortcut just like with samples.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-08-29 16:14

administrator   ~0004847

Good idea, yes, but will require some code to be rearranged to work properly.

Saga Musix

Saga Musix

2021-09-14 22:06

administrator   ~0004871

This is implemented as of r15696 / OpenMPT 1.30.00.49. I'm afraid I cannot backport this to OpenMPT 1.29 for now because of the bigger code changes this required which require more testing in order to not break anything. Please grab a test build from https://builds.openmpt.org/builds/ and see how this works for you.

Saga Musix

Saga Musix

2021-09-21 16:58

administrator   ~0004877

@a11cf0 did you give this a try yet?

a11cf0

a11cf0

2021-09-21 19:21

reporter   ~0004878

Yes, it works correctly. Many thanks again.

Issue History

Date Modified Username Field Change
2021-08-29 14:15 a11cf0 New Issue
2021-08-29 16:14 Saga Musix Note Added: 0004847
2021-08-29 16:14 Saga Musix Assigned To => Saga Musix
2021-08-29 16:14 Saga Musix Status new => assigned
2021-09-14 22:06 Saga Musix Status assigned => feedback
2021-09-14 22:06 Saga Musix Note Added: 0004871
2021-09-15 14:35 Saga Musix Target Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-09-21 16:58 Saga Musix Note Added: 0004877
2021-09-21 19:21 a11cf0 Note Added: 0004878
2021-09-21 19:21 a11cf0 Status feedback => assigned
2021-09-21 19:22 Saga Musix Status assigned => resolved
2021-09-21 19:22 Saga Musix Resolution open => fixed
2021-09-21 19:22 Saga Musix Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)