View Issue Details

IDProjectCategoryView StatusLast Update
0001488OpenMPTFile Format Supportpublic2021-11-14 00:11
ReporterSaga Musix Assigned ToSaga Musix  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Target VersionOpenMPT 1.30.01.00 / libopenmpt 0.6.0 (current stable)Fixed in VersionOpenMPT 1.30.01.00 / libopenmpt 0.6.0 (current stable) 
Summary0001488: Allow exporting OPL commands for native playback
Description

In order to play OpenMPT-made OPL tracks on real hardware, it could be useful to be able to export to a linear register dump format like DRO or VGM. This could be a new export option.

Things to consider:

  • Should there be an OPL2 mode? That would make sense for S3M. In which case...
    • OpenMPT does not include any delays when writing to OPL ports, because Opal (and OPL3) doesn't need them but OPL2 does. Need to generate artificial delays between register writes in the output file.
    • OpenMPT does not send any init commands such as Enable Waveform Select (m_opl->Port(1, 32)) , again because Opal doesn't need them. This means these commands would have to be added outside of the playback code.
  • Similar to OPL2 Enable Waveform Select, OpenMPT doesn't send the OPL3 enable command (m_opl_Port(0x105, 1)), because Opal doesn't need it. Again this needs to be written to the file outside of the playback code.
TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-11-14 00:11

administrator   ~0004895

Implemented (OPL3-only) in r15937. Might add custom tagging for VGM later, right now it implicitly uses the title/artist/comments from the module.

Issue History

Date Modified Username Field Change
2021-08-17 18:35 Saga Musix New Issue
2021-08-17 18:39 Saga Musix Description Updated
2021-11-10 19:16 Saga Musix Assigned To => Saga Musix
2021-11-10 19:16 Saga Musix Status new => assigned
2021-11-10 22:49 Saga Musix Target Version => OpenMPT 1.30.01.00 / libopenmpt 0.6.0 (current stable)
2021-11-14 00:11 Saga Musix Note Added: 0004895
2021-11-14 00:11 Saga Musix Status assigned => resolved
2021-11-14 00:11 Saga Musix Resolution open => fixed
2021-11-14 00:11 Saga Musix Fixed in Version => OpenMPT 1.30.01.00 / libopenmpt 0.6.0 (current stable)