View Issue Details

IDProjectCategoryView StatusLast Update
0001457OpenMPTGeneralpublic2021-09-12 22:43
ReporterIcy_Guidance Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.29.09.00 / libopenmpt 0.5.8 (upgrade first) 
Target VersionOpenMPT 1.29.12.00 / libopenmpt 0.5.11 (current stable)Fixed in VersionOpenMPT 1.29.12.00 / libopenmpt 0.5.11 (current stable) 
Summary0001457: Percussion samples in imported MIDI libraries are silent.
Description

Any time I import a MIDI soundfont, the percussion samples are silent. How do I fix this?

TagsNo tags attached.
Has the bug occurred in previous versions?No.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-05-08 11:01

administrator   ~0004760

Please provide an example soundfont you see the problem happening with, and explain what you are doing with it. I see no problems with soundfonts here.

PS: Please do not modify the priority of an issue. Just because a feature that may not be working fully is important to you, doesn't mean that it will our top priority to fix it.

Saga Musix

Saga Musix

2021-06-07 17:32

administrator   ~0004793

Last edited: 2021-06-07 17:33

In this thread some soundfonts have been mentioned: 4GMGSMT.SF2, GeneralUserGS144.sf2 and GeneralUser GS v1.471.sf2

I can reproduce the issue with the GeneralUser soundfont but not with e.g. the Yamaha XG soundset or GM.DLS.

Saga Musix

Saga Musix

2021-06-07 18:24

administrator   ~0004794

Problem was introduced in OpenMPT 1.29. Potentially caused by support for global zones.

Icy_Guidance

Icy_Guidance

2021-06-11 00:42

reporter   ~0004798

Any way to fix this with soundfonts like the Ultimate Genesis Soundfont?

Saga Musix

Saga Musix

2021-06-11 07:09

administrator   ~0004799

Eventually, sure. I did have a look at it earlier this week and couldn't come up with a fix yet. Soundfonts are complicated.

Saga Musix

Saga Musix

2021-06-11 07:09

administrator   ~0004800

As a temporary workaround you could convert those soundfont instruments to individual instruments (e.g. SFZ) with a program like Awave Studio and then assign those to the MIDI library.

Saga Musix

Saga Musix

2021-08-01 17:34

administrator   ~0004820

This was caused by support for global regions that was introduced in OpenMPT 1.29. r15475 fixes this and will be part of the next OpenMPT update.

Issue History

Date Modified Username Field Change
2021-05-08 02:45 Icy_Guidance New Issue
2021-05-08 02:46 Icy_Guidance Severity minor => major
2021-05-08 11:01 Saga Musix Priority immediate => normal
2021-05-08 11:01 Saga Musix Severity major => minor
2021-05-08 11:01 Saga Musix Note Added: 0004760
2021-06-07 17:32 Saga Musix Note Added: 0004793
2021-06-07 17:33 Saga Musix Note Edited: 0004793
2021-06-07 18:24 Saga Musix Note Added: 0004794
2021-06-11 00:42 Icy_Guidance Note Added: 0004798
2021-06-11 07:09 Saga Musix Note Added: 0004799
2021-06-11 07:09 Saga Musix Note Added: 0004800
2021-06-12 00:09 Icy_Guidance Has the bug occurred in previous versions? => No.
2021-08-01 17:30 Saga Musix Assigned To => Saga Musix
2021-08-01 17:30 Saga Musix Status new => assigned
2021-08-01 17:34 Saga Musix Fixed in Version => OpenMPT 1.29.12.00 / libopenmpt 0.5.11 (current stable)
2021-08-01 17:34 Saga Musix Target Version => OpenMPT 1.29.12.00 / libopenmpt 0.5.11 (current stable)
2021-08-01 17:34 Saga Musix Note Added: 0004820
2021-08-01 17:34 Saga Musix Status assigned => resolved
2021-08-01 17:34 Saga Musix Resolution open => fixed
2021-09-11 14:13 StarWolf3000 Relationship added related to 0001504
2021-09-12 22:43 Saga Musix Relationship deleted related to 0001504