View Issue Details

IDProjectCategoryView StatusLast Update
0001437OpenMPTGeneralpublic2021-04-08 20:58
Reporterveksha Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.30.00.* (current testing) 
Target VersionOpenMPT 1.29.09.00 / libopenmpt 0.5.8 (current stable)Fixed in VersionOpenMPT 1.29.09.00 / libopenmpt 0.5.8 (current stable) 
Summary0001437: Inserting Separator by pressing "I" is replacing current pattern instead of inserting it.
Description

Inserting Separator by pressing "I" is not function the same as choosing "Insert Separator" by clicking menu item.
It replaces current pattern (like "-" key press).

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-03-30 23:55

administrator   ~0004694

True, the shortcut doesn't exactly do the same as what the context menu entry does. The shortcut's functionality is intended though, so we will need to add a new shortcut in addition to the existing one.

Saga Musix

Saga Musix

2021-04-08 20:58

administrator   ~0004708

r14561 adds a new keyboard shorcut which does the same thing as the context menu entry does (Ctrl+Insert by default).

Issue History

Date Modified Username Field Change
2021-03-30 23:51 veksha New Issue
2021-03-30 23:55 Saga Musix Note Added: 0004694
2021-03-30 23:55 Saga Musix Assigned To => Saga Musix
2021-03-30 23:55 Saga Musix Status new => assigned
2021-04-08 20:58 Saga Musix Status assigned => resolved
2021-04-08 20:58 Saga Musix Resolution open => fixed
2021-04-08 20:58 Saga Musix Fixed in Version => OpenMPT 1.29.09.00 / libopenmpt 0.5.8 (current stable)
2021-04-08 20:58 Saga Musix Target Version => OpenMPT 1.29.09.00 / libopenmpt 0.5.8 (current stable)
2021-04-08 20:58 Saga Musix Note Added: 0004708