View Issue Details

IDProjectCategoryView StatusLast Update
0001421OpenMPTlibopenmptpublic2021-02-21 17:11
Reporterbjourne Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Product VersionOpenMPT 1.29.07.00 / libopenmpt 0.5.5 (current stable) 
Summary0001421: MOD with lots of position jump effects
Description

Hi, I believe openmpt reports the wrong duration for a MOD file that uses an excessive amount of backwards position jumps. The MOD file is here: https://modarchive.org/index.php?request=view_by_moduleid&query=97365 I don't know how it should be handled but I don't think it should be looped for 18 minutes.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-02-20 12:21

administrator   ~0004645

The file may be broken from a user's perspective (lots of repeated patterns that are not meant to be played) but there is nothing from the software's perspective to understand this, because what the file does is technically perfectly valid. You can remove the excessive references to pattern 0 in the order list (only the first one should stay) and re-save the file, then it will be played as intended.

bjourne

bjourne

2021-02-20 17:43

reporter   ~0004646

Yes I know that I can fix the module by editing in a tracker. But the issue is that OpenMPT reports the wrong duration for subsongs. Here is another one: http://modarchive.org/index.php?request=view_by_moduleid&query=125974 The duration for subsong 3 is seven seconds but it actually is much longer than that.

Saga Musix

Saga Musix

2021-02-20 17:51

administrator   ~0004647

In both modules, the subsongs jump to a pattern that has already been played by another subsong. It's by design that it stops counting once a row is hit that has already been played.

You will find that e.g. XMPlay handles both of those cases exactly the same as OpenMPT does. It's not up for debate to change that behaviour.

Issue History

Date Modified Username Field Change
2021-02-20 05:03 bjourne New Issue
2021-02-20 12:21 Saga Musix Note Added: 0004645
2021-02-20 12:21 Saga Musix Status new => closed
2021-02-20 12:21 Saga Musix Resolution open => not fixable
2021-02-20 17:43 bjourne Status closed => feedback
2021-02-20 17:43 bjourne Resolution not fixable => reopened
2021-02-20 17:43 bjourne Note Added: 0004646
2021-02-20 17:51 Saga Musix Note Added: 0004647
2021-02-21 17:11 Saga Musix Status feedback => closed
2021-02-21 17:11 Saga Musix Resolution reopened => not fixable