View Issue Details

IDProjectCategoryView StatusLast Update
0001388OpenMPTPlugins / VSTpublic2020-11-24 16:52
ReporterAntonZab Assigned To 
PrioritynormalSeveritymajorReproducibilityunable to reproduce
Status closedResolutionno change required 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.29.05.00 / libopenmpt 0.5.3 (current stable) 
Summary0001388: VST Plugins for MT2
Description

Hello. There is one MT2 file. VST plugins are required to play it. Such plugins are not available and are not supported. How do I play the file?

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

AntonZab

AntonZab

2020-11-16 14:39

reporter  

2.png (23,062 bytes)   
2.png (23,062 bytes)   
AntonZab

AntonZab

2020-11-16 14:41

reporter   ~0004510

abend.zip (7,826 bytes)
Saga Musix

Saga Musix

2020-11-16 14:53

administrator   ~0004511

Most of those plugins are shipped with MadTracker 2 (but are also available separately), so you can add the VST folder from a MadTracker 2 installation through OpenMPT's plugin manager. The rest of the plugins can be found through KVR Audio or your favourite search engine. This is not an OpenMPT bug.

AntonZab

AntonZab

2020-11-17 16:08

reporter   ~0004512

I found all but one. Drumatic_22. Another question. Is it possible to add VST plugin support to Winamp player plugin

Saga Musix

Saga Musix

2020-11-17 16:14

administrator   ~0004513

Last edited: 2020-11-17 16:15

View 2 revisions

No, VST support is not currently planned for libopenmpt and players that depend on it. One of the problems is that VSTs are typically not redistributable. It's best to render such files to a streamed format for your media player. It also has the advantage that it saves a lot of CPU processing power as many VSTs require lots of CPU power.

Issue History

Date Modified Username Field Change
2020-11-16 14:39 AntonZab New Issue
2020-11-16 14:39 AntonZab File Added: 2.png
2020-11-16 14:41 AntonZab Note Added: 0004510
2020-11-16 14:41 AntonZab File Added: abend.zip
2020-11-16 14:43 AntonZab Reproducibility have not tried => unable to reproduce
2020-11-16 14:53 Saga Musix Note Added: 0004511
2020-11-17 16:08 AntonZab Note Added: 0004512
2020-11-17 16:14 Saga Musix Note Added: 0004513
2020-11-17 16:15 Saga Musix Note Edited: 0004513 View Revisions
2020-11-24 16:52 Saga Musix Status new => closed
2020-11-24 16:52 Saga Musix Resolution open => no change required