View Issue Details

IDProjectCategoryView StatusLast Update
0001385OpenMPTFeature Requestpublic2020-11-06 21:14
ReporterHxOr1337 Assigned ToSaga Musix  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.29.03.00 / libopenmpt 0.5.2 (upgrade first) 
Target VersionOpenMPT 1.29.06.00 / libopenmpt 0.5.4 (upcoming stable)Fixed in VersionOpenMPT 1.29.06.00 / libopenmpt 0.5.4 (upcoming stable) 
Summary0001385: Add back in "=" for "==" cut
Description

After the new update the "=" button doesn't insert "==" cut, and it really bothers me that I no longer have a shortcut to insert it

Steps To Reproduce

Press "=" on a new line

TagsNo tags attached.
Has the bug occurred in previous versions?Maybe
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2020-11-05 08:00

administrator   ~0004498

OpenMPT doesn't remove keyboard shortcuts on updates (there is no code to do that).

Maybe you reinstalled OpenMPT in a different place with a portable installation, or on a different machine, and your previous keyboard configuration was lost. Or maybe you configured some other keyboard action accidentally to use the same key, which may then have removed the association from the Note Off command. OpenMPT's keyboard configuration is fully configurable, you can easily add the key back if it went missing.

Saga Musix

Saga Musix

2020-11-05 08:00

administrator   ~0004499

Also, OpenMPT 1.29.03.00 is not the latest version, please always upgrade to the latest version before reporting a problem.

Lachesis

Lachesis

2020-11-05 09:47

reporter   ~0004500

I can confirm I have encountered this issue with recent portable Windows builds. The note cut and note off shortcuts do not work until I manually reset the bindings or copy the bindings from a previous directory. Screenshots from a freshly extracted copy of 1.29.05.

image.png (31,683 bytes)   
image.png (31,683 bytes)   
image-2.png (9,228 bytes)   
image-2.png (9,228 bytes)   
image-3.png (32,057 bytes)   
image-3.png (32,057 bytes)   
image-4.png (9,244 bytes)   
image-4.png (9,244 bytes)   
Saga Musix

Saga Musix

2020-11-05 09:53

administrator   ~0004501

Can you please mention which keyboard layout you are using?

Lachesis

Lachesis

2020-11-05 10:04

reporter   ~0004502

Sorry for leaving that bit out. I'm using the US QWERTY layout.

Saga Musix

Saga Musix

2020-11-05 18:57

administrator   ~0004503

I see the issue now. The default keybindings contained some legacy commands that were no longer imported correctly as of OpenMPT 1.29. r13808 / OpenMPT 1.25.05.02 should hopefully fix this. You will be able to obtain this build in a few hours from https://builds.openmpt.org/builds/

Lachesis

Lachesis

2020-11-06 21:14

reporter   ~0004504

I've confirmed that Note Cut, Note Off, and Note Fade all have correct bindings in the r13808 build and now work without requiring reconfiguration.

Issue History

Date Modified Username Field Change
2020-11-05 01:26 HxOr1337 New Issue
2020-11-05 08:00 Saga Musix Priority high => low
2020-11-05 08:00 Saga Musix Reproducibility always => unable to reproduce
2020-11-05 08:00 Saga Musix Note Added: 0004498
2020-11-05 08:00 Saga Musix Note Added: 0004499
2020-11-05 09:47 Lachesis Note Added: 0004500
2020-11-05 09:47 Lachesis File Added: image.png
2020-11-05 09:47 Lachesis File Added: image-2.png
2020-11-05 09:47 Lachesis File Added: image-3.png
2020-11-05 09:47 Lachesis File Added: image-4.png
2020-11-05 09:53 Saga Musix Note Added: 0004501
2020-11-05 10:04 Lachesis Note Added: 0004502
2020-11-05 17:57 Saga Musix Assigned To => Saga Musix
2020-11-05 17:57 Saga Musix Status new => assigned
2020-11-05 18:57 Saga Musix Status assigned => feedback
2020-11-05 18:57 Saga Musix Fixed in Version => OpenMPT 1.29.06.00 / libopenmpt 0.5.4 (upcoming stable)
2020-11-05 18:57 Saga Musix Target Version => OpenMPT 1.29.06.00 / libopenmpt 0.5.4 (upcoming stable)
2020-11-05 18:57 Saga Musix Note Added: 0004503
2020-11-06 21:14 Lachesis Note Added: 0004504
2020-11-06 21:14 Saga Musix Priority low => normal
2020-11-06 21:14 Saga Musix Reproducibility unable to reproduce => always
2020-11-06 21:14 Saga Musix Status feedback => resolved
2020-11-06 21:14 Saga Musix Resolution open => fixed