View Issue Details

IDProjectCategoryView StatusLast Update
0001364OpenMPTAccessibilitypublic2020-09-26 19:49
Reportera11cf0 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.30.00.* (current testing) 
Summary0001364: Accessibility of the treeview is broken
Description

The accessibility of the lower half of the main treeview is broken in a couple of recent 1.30.x revisions.
When navigating the files/folders screen readers report randomly shuffled filenames from a current or even a parent directory instead of what is expected.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0001362 resolvedSaga Musix Bottom part of treeview duplicates entries every refresh trigged 

Activities

Saga Musix

Saga Musix

2020-09-21 14:07

administrator   ~0004441

Can you please confirm which revision you are using, and if updating to the latest test version helps? This sounds like a duplicate of 0001362 which I fixed a week ago.

a11cf0

a11cf0

2020-09-21 14:20

reporter   ~0004442

Sorry, I've forgotten to check revision numbers. I'm using r13619 which is the latest build available from the buildbot, but this seems to be fixed in r13620.

Saga Musix

Saga Musix

2020-09-26 17:58

administrator   ~0004445

Builds are available again. Can you confirm the issue is fixed?

a11cf0

a11cf0

2020-09-26 19:48

reporter   ~0004446

Yes it's fixed. Thanks

Issue History

Date Modified Username Field Change
2020-09-21 14:06 a11cf0 New Issue
2020-09-21 14:07 Saga Musix Note Added: 0004441
2020-09-21 14:20 a11cf0 Note Added: 0004442
2020-09-26 17:58 Saga Musix Note Added: 0004445
2020-09-26 17:58 Saga Musix Assigned To => Saga Musix
2020-09-26 17:58 Saga Musix Status new => feedback
2020-09-26 19:48 a11cf0 Note Added: 0004446
2020-09-26 19:48 a11cf0 Status feedback => assigned
2020-09-26 19:49 Saga Musix Relationship added duplicate of 0001362
2020-09-26 19:49 Saga Musix Status assigned => closed
2020-09-26 19:49 Saga Musix Resolution open => duplicate