View Issue Details

IDProjectCategoryView StatusLast Update
0001356OpenMPTUser Interfacepublic2020-08-24 17:40
Reporternyanpasu64 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.29.02.00 / libopenmpt 0.5.1 (upgrade first) 
Target VersionOpenMPT 1.29.03.00 / libopenmpt 0.5.2 (current stable)Fixed in VersionOpenMPT 1.29.03.00 / libopenmpt 0.5.2 (current stable) 
Summary0001356: Right-clicking order list and selecting "Pattern Properties..." edits current pattern properties, not pattern clicked
Description

In the order list, right-clicking a pattern not currently being edited, and clicking "Pattern Properties..." actually edits the current pattern's properties. But right-clicking an unoccupied cell doesn't let you edit the current pattern's properties.

Clicking the question mark toolbar icon (which I had a bit of trouble finding, since there's no label and no menu entry) edits the currently editing pattern's properties, regardless if it's in the sequence or not.

Maybe right-clicking the order list was intended to edit the pattern you right-clicked.

TagsNo tags attached.
Has the bug occurred in previous versions?Didn't check
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2020-08-24 12:05

administrator   ~0004426

Maybe right-clicking the order list was intended to edit the pattern you right-clicked.

Back when this functionality it was introduced, right-clicking a pattern would always make it the current pattern, so there was no difference. Anyway, now that right-clicking an order list entry no longer activates that pattern, it indeed needs to be fixed.

nyanpasu64

nyanpasu64

2020-08-24 12:42

reporter   ~0004427

(Clicking the top left corner of the pattern editor "main panel" also opens pattern properties. Didn't know that was possible before.)

Saga Musix

Saga Musix

2020-08-24 12:43

administrator   ~0004428

It's even documented in the manual and the FAQ ;)

Saga Musix

Saga Musix

2020-08-24 17:40

administrator   ~0004429

Fixed in r13479.

Issue History

Date Modified Username Field Change
2020-08-24 07:07 nyanpasu64 New Issue
2020-08-24 11:51 Saga Musix Assigned To => Saga Musix
2020-08-24 11:51 Saga Musix Status new => assigned
2020-08-24 12:05 Saga Musix Note Added: 0004426
2020-08-24 12:05 Saga Musix Target Version => OpenMPT 1.29.03.00 / libopenmpt 0.5.2 (current stable)
2020-08-24 12:42 nyanpasu64 Note Added: 0004427
2020-08-24 12:43 Saga Musix Note Added: 0004428
2020-08-24 17:40 Saga Musix Status assigned => resolved
2020-08-24 17:40 Saga Musix Resolution open => fixed
2020-08-24 17:40 Saga Musix Fixed in Version => OpenMPT 1.29.03.00 / libopenmpt 0.5.2 (current stable)
2020-08-24 17:40 Saga Musix Note Added: 0004429