View Issue Details

IDProjectCategoryView StatusLast Update
0001318OpenMPTUser Interfacepublic2020-05-15 20:26
ReporterASIKWUSpulse Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.28.10.00 / libopenmpt 0.4.12 (upgrade first) 
Target VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)Fixed in VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable) 
Summary0001318: PCM-data for some sample-items in Tree View doesn't get loaded everytime
Description

After a while when I browsed through modules and it's samples in the "extract-tree" half (lower one) of the tree view, some samples doesn't get loaded correctly for some sample-items in the list - every setting seems to be loaded except for the PCM-data itself.

Steps To Reproduce
  1. browse content from a module in the lower "extract-part" of the Tree View
  2. Try previewing some of the samples - at fresh start they sound normal
  3. Directly browse a new module
  4. Preview all samples

I did step 3 about 2-4 times and then at step 4 some samples wouldn't sound right at preview
Try dragging them into the sample-editor too to also see the incorrect sample-data

TagsNo tags attached.
Has the bug occurred in previous versions?Last time I've came across this was probably one or two years ago, so probably yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2020-05-02 20:27

administrator   ~0004305

Last edited: 2020-05-02 20:28

View 2 revisions

When it happens again, it would be interesting to know if

  • all samples fail to load, or if smaller samples still load
  • do OPL instruments still load?
  • does it only happen when extracting samples from a module or also when loading WAV/FLAC/etc. files?
ASIKWUSpulse

ASIKWUSpulse

2020-05-15 14:31

reporter   ~0004315

I tried to repeat it, and in case it could be relevant, I had no module open. I browsed like 5-8 different modules in both 32-bit and 64-bit with no sign of the bug.

I can't remember what i really did before triggering it more than a module being open - though I don't dare to guarantee that it won't happen with no module open

It's a bit leaning towards allocation issues, like you first initially thought. Too bad I didn't memory dump the program when it happened, so I could upload it here for wonky-activity inspection :)

Saga Musix

Saga Musix

2020-05-15 14:42

administrator   ~0004316

I was able to reproduce a similar issue which probably has the same root cause as what you reported. At some point, some sample slots were no longer being replaced with the correct samples but old samples from a previous module were still there instead. It's definitely not a low-memory issues because other, bigger samples were still loading. I'll look into this tonight.

Saga Musix

Saga Musix

2020-05-15 14:48

administrator   ~0004317

After thinking a bit more about what I just observed, it's clear now what happened in my case, but I don't know if that's the same as what happened to you: In my case, I loaded some MPTM files with external samples, and the external sample association was not cleared. So when loading the next file into the tree view, OpenMPT still tried to load those external samples into the same sample slots. In case the external sample cannot be found, this could explain why the sample data could not be loaded anymore.

Do you have any MPTM modules with (potentially non-existing) external sample associations which could cause the same issue for you?

ASIKWUSpulse

ASIKWUSpulse

2020-05-15 15:07

reporter   ~0004318

Ok, nevermind - I repeated step 3-4 for 15 modules and on the 15th module the bug showed up (still with no module open). This is in 64-bit.
Info I managed to collect:

General info of the modules I opened:
Version Created (- Saved) / Module-type
1. 1.28.03.00 / .IT
2. (no version info available) / .MOD
3. 1.27.11.00 / .IT
4. 1.24.04.00 / .IT
5. (no version info available) / .MOD
6. 1.23.05.00 - 1.24.01.. / .IT
7. 1.28.03.00 - 1.28.04.. / .MPTM
8. 1.23.05.00 / .MPTM
9. 1.28.00.33 / .IT
10. Same as previous / .MPTM
11. 1.24.01.00 / .IT
12. 1.28.00.40 / .MPTM
13. 1.28.00.33 / .MPTM
14. Same as previous / .MPTM
15. 1.28.02.00 - 1.28.07.. / .MPTM

Noticed now that up until the last module, I'd loaded two modules created with test-build versions. actually feels like it could be what was causing the bug, but maybe worth a verification.

Let me know if a memory dump would help too, since I have one.

Saga Musix

Saga Musix

2020-05-15 16:05

administrator   ~0004319

Test builds certainly shouldn't make any difference. But it would still be interesting to know if any of those MPTMs use external samples. If they don't, it would be good to know if it always happens after one specific file from that list has been loaded.

Saga Musix

Saga Musix

2020-05-15 18:57

administrator   ~0004321

If external samples were involved, the latest build at https://builds.openmpt.org/builds/auto/openmpt/bin.win64/1.29/ should fix this issue. Please test it.

ASIKWUSpulse

ASIKWUSpulse

2020-05-15 20:14

reporter   ~0004324

There were external samples yes. I'll try it

ASIKWUSpulse

ASIKWUSpulse

2020-05-15 20:26

reporter   ~0004325

I repeated the exact same test, with the exact same modules but also a bunch more to be a bit more sure, and everything seems to work as it should now.

Saga Musix

Saga Musix

2020-05-15 20:26

administrator   ~0004326

Great to hear, seems like the external samples were indeed the culprit then!

Issue History

Date Modified Username Field Change
2020-05-02 20:09 ASIKWUSpulse New Issue
2020-05-02 20:11 ASIKWUSpulse Summary PCM-data for some sample-items in Tree View doesn't get loaded sometimes => PCM-data for some sample-items in Tree View doesn't get loaded everytime
2020-05-02 20:27 Saga Musix Note Added: 0004305
2020-05-02 20:28 Saga Musix Note Edited: 0004305 View Revisions
2020-05-15 14:31 ASIKWUSpulse Note Added: 0004315
2020-05-15 14:42 Saga Musix Note Added: 0004316
2020-05-15 14:48 Saga Musix Note Added: 0004317
2020-05-15 15:07 ASIKWUSpulse Note Added: 0004318
2020-05-15 16:05 Saga Musix Note Added: 0004319
2020-05-15 18:57 Saga Musix Note Added: 0004321
2020-05-15 20:14 ASIKWUSpulse Note Added: 0004324
2020-05-15 20:26 ASIKWUSpulse Note Added: 0004325
2020-05-15 20:26 Saga Musix Note Added: 0004326
2020-05-15 20:26 Saga Musix Assigned To => Saga Musix
2020-05-15 20:26 Saga Musix Status new => assigned
2020-05-15 20:26 Saga Musix Status assigned => resolved
2020-05-15 20:26 Saga Musix Resolution open => fixed
2020-05-15 20:26 Saga Musix Fixed in Version => OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)
2020-05-15 20:26 Saga Musix Target Version => OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)