View Issue Details

IDProjectCategoryView StatusLast Update
0001309OpenMPTPlayer input plugins (xmp-openmpt, in_openmpt)public2020-04-13 13:36
ReporterWizArthur Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upgrade first) 
Target VersionOpenMPT 1.28.10.00 / libopenmpt 0.4.12 (upgrade first)Fixed in VersionOpenMPT 1.28.10.00 / libopenmpt 0.4.12 (upgrade first) 
Summary0001309: IT vibrato speed incorrect
Description

Problem observed in foo_openmpt54 0.4.11 with IT files. Vibrato speed appears to be incorrect (in this case too fast). Not sure if this only applies to certain hex values or the use of the Kxx command. Vibrato playback tested correctly in IT, Schism Tracker, and ModPlug Player.

Steps To Reproduce

Play back attached demonstration track using foo_openmpt54 followed by a different player and note vibrato speed on note decay.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

WizArthur

WizArthur

2020-04-06 03:44

reporter   ~0004270

Demo track for IT vibrato speed issue.

Saga Musix

Saga Musix

2020-04-06 06:57

administrator   ~0004271

The file seems to be missing - please be sure that it's not too big and it's a supported file format (put it in a ZIP or 7Z file)

WizArthur

WizArthur

2020-04-06 17:04

reporter   ~0004272

Thanks, Saga Musix. Attempting attachment again.

a2vibrato.zip (2,414 bytes)
Saga Musix

Saga Musix

2020-04-06 17:51

administrator   ~0004273

Okay, seems like IT doesn't increment the vibrato position on the first tick in Old Effects mode, which is similar to what other trackers do. Should be easy to fix.

Saga Musix

Saga Musix

2020-04-06 17:59

administrator   ~0004274

Fixed in r12608 (this broke in r8805 / OpenMPT 1.27.00.61).

Issue History

Date Modified Username Field Change
2020-04-06 03:41 WizArthur New Issue
2020-04-06 03:44 WizArthur Note Added: 0004270
2020-04-06 06:57 Saga Musix Note Added: 0004271
2020-04-06 17:04 WizArthur Note Added: 0004272
2020-04-06 17:04 WizArthur File Added: a2vibrato.zip
2020-04-06 17:50 Saga Musix Assigned To => Saga Musix
2020-04-06 17:50 Saga Musix Status new => assigned
2020-04-06 17:51 Saga Musix Note Added: 0004273
2020-04-06 17:59 Saga Musix Note Added: 0004274
2020-04-06 18:00 Saga Musix Status assigned => resolved
2020-04-06 18:00 Saga Musix Resolution open => fixed
2020-04-06 18:00 Saga Musix Fixed in Version => OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)
2020-04-06 18:00 Saga Musix Target Version => OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)
2020-04-13 13:36 Saga Musix Fixed in Version OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable) => OpenMPT 1.28.10.00 / libopenmpt 0.4.12 (upgrade first)
2020-04-13 13:36 Saga Musix Target Version OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable) => OpenMPT 1.28.10.00 / libopenmpt 0.4.12 (upgrade first)
2020-05-24 19:25 manx Category Player input plugins (xmp-openmpt, in_openmpt, foo_openmpt) => Player input plugins (xmp-openmpt, in_openmpt)