View Issue Details

IDProjectCategoryView StatusLast Update
0000013OpenMPT[All Projects] User Interfacepublic2014-02-16 15:11
ReporterSaga MusixAssigned ToSaga Musix 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.23.01.00 (upgrade first)Fixed in VersionOpenMPT 1.23.01.00 (upgrade first) 
Summary0000013: Scroll Lock key doesn't work
Description

You can't use Scroll Lock in your keyboard layout, even though it's available. If you press it, it will automatically be deactivated again and no action will be triggered in OpenMPT.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, AFAIK all versions using the "new" keyboard manager.
Tested code revision (in case you know it)

Relationships

has duplicate 0000202 closed Scroll lock assigned to "Pattern Editor General - Toggle follow song" doesn't work as suspected 

Activities

LPChip

LPChip

2011-10-21 16:09

manager   ~0000530

Interesting. If you use CTRL-Scroll Lock, it does register correctly.

LPChip

LPChip

2014-02-14 14:14

manager   ~0001526

Another interesting thing, if you do not assign the scroll lock key, pressing it will toggle your indicator light on the key. If you do assign it, it will be triggered twice, like OpenMPT also triggers scroll lock and thus undoing the action aka triggering itself.

In fact, if you set scroll lock as a key-up action, holding down scroll lock performs the action, then releasing scroll lock will undo it.

So OpenMPT does actually trigger the action, but it does it twice which undoes the previous action.

Saga Musix

Saga Musix

2014-02-16 01:23

administrator   ~0001533

Yeah, it seems like the code that prevents the caps/num/scroll lock keys from lighting up creates this problem (the other two keys have the same problem). I'll see if I can come up with something clever that prevents them from lighting up but still work as expected.

LPChip

LPChip

2014-02-16 14:45

manager   ~0001534

Right.

What I'd do is when a keypress is given, Set a variable that we've received the key once. (like a counter) When the action is triggered again, the counter is raised another time. If the counter hits 2, its reset and the actual action is performed.

Saga Musix

Saga Musix

2014-02-16 14:52

administrator   ~0001535

Yeah, except that exactly this is being done and it doesn't help because OpenMPT's input system is a bit more complicated than that. You really don't need to help me with programming.

Saga Musix

Saga Musix

2014-02-16 15:11

administrator   ~0001536

Fixed in r3723.

Issue History

Date Modified Username Field Change
2010-11-06 11:36 Saga Musix New Issue
2010-11-06 11:43 Saga Musix Status new => confirmed
2011-10-21 16:06 Saga Musix Relationship added has duplicate 0000202
2011-10-21 16:09 LPChip Note Added: 0000530
2014-02-14 14:14 LPChip Note Added: 0001526
2014-02-16 01:23 Saga Musix Note Added: 0001533
2014-02-16 01:30 Saga Musix Assigned To => Saga Musix
2014-02-16 01:30 Saga Musix Status confirmed => assigned
2014-02-16 14:45 LPChip Note Added: 0001534
2014-02-16 14:52 Saga Musix Note Added: 0001535
2014-02-16 15:11 Saga Musix Note Added: 0001536
2014-02-16 15:11 Saga Musix Status assigned => resolved
2014-02-16 15:11 Saga Musix Resolution open => fixed
2014-02-16 15:11 Saga Musix Fixed in Version => OpenMPT 1.23.01.00 (upgrade first)
2014-02-16 15:11 Saga Musix Target Version => OpenMPT 1.23.01.00 (upgrade first)