View Issue Details

IDProjectCategoryView StatusLast Update
0001282OpenMPTUser Interfacepublic2019-11-10 14:57
ReporterTheRealByteRaver Assigned ToSaga Musix  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindows 
Product VersionOpenMPT 1.28.08.00 / libopenmpt 0.4.9 (current stable) 
Target VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)Fixed in VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable) 
Summary0001282: crash when expanding single-row pattern
Description

Being a complete n00b in mpt, I opened a song for editing and wanted the patterns of that song to be 64 rows long (they were 48 rows long). I didn't now how to do that so I shrunk the pattern by clicking the X icon (labeled "shrink pattern") repeatedly until the pattern was zero (or 1) row long. When I then expanded the pattern again by clicking the icon right next to it (labeled "expand pattern"), MPT just closed without warning or error message.

Steps To Reproduce

I used mechanic.it ("Mechanical And Supernaddy"), an .MDL file resaved as .IT with MPT, made by Jari Karppinen.

  • emptied the pattern sequence table to a few entries, only pattern nr 0
  • emptied the pattern: removed all note, instrument & effect data
  • kept shrinking it until it had one row left
  • expanded the row again -> shutdown of MPT

I was unable to reproduce the bug by following the same steps with another module (xm file saved to .it, patterns shrunk & expanded again)

Additional Information

Disclaimer: I tried to check if this bug reported before, but couldn't find any mention of it.
I used the 32 bit version of MPT, even though I have a 64bit OS. I am not using any VST or other plugins, just vanilla OpenMPT.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-11-10 14:57

administrator   ~0004148

Fixed in r12329. You can set OpenMPT's update channel to "next" and wait for version 1.28.08.03 to arrive there (should be available by tomorrow), or wait for the next stable release.

FWIW, the problem only occurs after halving a pattern that had an odd number of rows, in your example this was triggered by resizing the pattern from 3 to 1 row.

Issue History

Date Modified Username Field Change
2019-11-10 14:38 TheRealByteRaver New Issue
2019-11-10 14:55 Saga Musix Assigned To => Saga Musix
2019-11-10 14:55 Saga Musix Status new => assigned
2019-11-10 14:55 Saga Musix Target Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)
2019-11-10 14:55 Saga Musix Summary crash when expanding zero row pattern => crash when expanding single-row pattern
2019-11-10 14:57 Saga Musix Note Added: 0004148
2019-11-10 14:57 Saga Musix Status assigned => resolved
2019-11-10 14:57 Saga Musix Resolution open => fixed
2019-11-10 14:57 Saga Musix Fixed in Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)