View Issue Details

IDProjectCategoryView StatusLast Update
0001279OpenMPT[All Projects] Plugins / VSTpublic2019-11-06 07:36
ReporterSu Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.28.08.00 / libopenmpt 0.4.9 (current stable) 
Target VersionFixed in Version 
Summary0001279: opl samples do not send audio to plugins not labeled "master"
Description

the new opl instruments don't seem to send audio through vst plugins unless the latter are set to "master". if they're only assigned in the instrument tab, or even on the channel, they don't work.

Steps To Reproduce
  • create new opl sample
  • enter notes in a channel
  • assign an audio plugin to the channel
  • play the module and observe that the sample is unaffected.
Additional Information

i've searched the bugtracker and the forums and couldn't find anything on this behaviour.

TagsNo tags attached.
Has the bug occurred in previous versions?untested
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-11-06 07:36

administrator   ~0004141

Last edited: 2019-11-06 07:36

View 2 revisions

The OPL chip has a single combined stereo output and this is also how OPL emulators work in genral. As such, there is no way to "extract" the output of a single OPL voice from the stereo mix and send it to a specific plugin. If instrument 1 was assigned to plugin 1 and instrument 2 to plugin 2, there would be no way to know how to "split" the signal because it's not possible.

In the future we might be using a separate OPL chip instance for each instrument in MPTM format which would enable us to work around this limitation, but until then there is nothing that can be done about the current behaviour - it's very much by design.

Issue History

Date Modified Username Field Change
2019-11-05 23:24 Su New Issue
2019-11-05 23:26 Su Steps to Reproduce Updated View Revisions
2019-11-06 07:36 Saga Musix Note Added: 0004141
2019-11-06 07:36 Saga Musix Status new => closed
2019-11-06 07:36 Saga Musix Resolution open => not fixable
2019-11-06 07:36 Saga Musix Note Edited: 0004141 View Revisions