View Issue Details

IDProjectCategoryView StatusLast Update
0001278OpenMPT[All Projects] User Interfacepublic2019-11-05 20:23
ReporterASIKWUSpulse Assigned ToSaga Musix  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.08.00 / libopenmpt 0.4.9 (current stable) 
Target VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)Fixed in VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable) 
Summary0001278: Crash when entering notes in a pattern with empty order list
Description

Trying to put notes in the pattern in this specific module crashes the program

Steps To Reproduce

Do exactly as the description says in pattern view

Additional Information

More information in the included .zip once again which contains troubled module and crash dump

TagsNo tags attached.
Has the bug occurred in previous versions?Probably not
Tested code revision (in case you know it)

Activities

ASIKWUSpulse

ASIKWUSpulse

2019-11-02 11:04

reporter  

1_Mod1 Crash Dump.zip (172,572 bytes)
ASIKWUSpulse

ASIKWUSpulse

2019-11-02 11:25

reporter   ~0004131

Update: I have now found the problem again - and it's not what I first thought it would be. See this issue as its now updated

ASIKWUSpulse

ASIKWUSpulse

2019-11-02 11:31

reporter   ~0004132

Update: It seems to only happen with this specific module, weird enough

ASIKWUSpulse

ASIKWUSpulse

2019-11-02 15:17

reporter   ~0004136

Quickly found out that all of this is occuring through an access-bug of non-sequence patterns. Couldn't post this until now because of the spam-protection - took conclusions to fast. My bad :)

Saga Musix

Saga Musix

2019-11-05 20:23

administrator   ~0004140

Fixed in r12304 for OpenMPT 1.29, r12305 for OpenMPT 1.28.

You can either wait for those builds to become available on https://builds.openmpt.org/builds/ or set OpenMPT's update channel to "Next", in which case you should receive the same update.

Issue History

Date Modified Username Field Change
2019-11-02 11:04 ASIKWUSpulse New Issue
2019-11-02 11:04 ASIKWUSpulse File Added: 1_Mod1 Crash Dump.zip
2019-11-02 11:25 ASIKWUSpulse Note Added: 0004131
2019-11-02 11:27 ASIKWUSpulse Summary Quick tab-change after instrument preview-playing caused a crash => "No Instrument" in XM-format crashes the program
2019-11-02 11:27 ASIKWUSpulse Description Updated View Revisions
2019-11-02 11:27 ASIKWUSpulse Steps to Reproduce Updated View Revisions
2019-11-02 11:27 ASIKWUSpulse Reproducibility have not tried => always
2019-11-02 11:31 ASIKWUSpulse Summary "No Instrument" in XM-format crashes the program => "No Instrument" in this specific XM-module crashes the program
2019-11-02 11:31 ASIKWUSpulse Description Updated View Revisions
2019-11-02 11:31 ASIKWUSpulse Note Added: 0004132
2019-11-02 11:34 ASIKWUSpulse Summary "No Instrument" in this specific XM-module crashes the program => Crash from entering notes in the pattern
2019-11-02 11:34 ASIKWUSpulse Description Updated View Revisions
2019-11-02 11:35 ASIKWUSpulse Additional Information Updated View Revisions
2019-11-02 11:47 Saga Musix Summary Crash from entering notes in the pattern => Crash when entering notes in a pattern with empty order list
2019-11-02 11:47 Saga Musix Assigned To => Saga Musix
2019-11-02 11:47 Saga Musix Status new => assigned
2019-11-02 11:47 Saga Musix Target Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)
2019-11-02 15:17 ASIKWUSpulse Note Added: 0004136
2019-11-05 20:23 Saga Musix Status assigned => resolved
2019-11-05 20:23 Saga Musix Resolution open => fixed
2019-11-05 20:23 Saga Musix Fixed in Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)
2019-11-05 20:23 Saga Musix Note Added: 0004140