View Issue Details

IDProjectCategoryView StatusLast Update
0001260OpenMPT[All Projects] Playback Compatibilitypublic2019-09-11 17:27
ReporterSlender Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.06.00 / libopenmpt 0.4.6 (upgrade first) 
Target VersionFixed in Version 
Summary0001260: Odd panbrello behavior when extracting MO3 files
Description

Hi, I noticed that when extracting a MO3 file with UNMO3 and playing the extracted version, panbrello seems to pan at a much wider range than it normally would in the original MO3. Example file: https://www.dropbox.com/s/g65tj8cvhhinz4r/zuma.mo3?dl=1. When extracting this MO3, you'll notice that panbrello seems to pan over a much wider range than it does in the original MO3.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-09-11 06:34

administrator   ~0004059

Are you sure that's the right file? There is not a single panbrello effect in those patterns.

Besides, there is no such thing as an "original" MO3. The original would be an IT file, and older MO3 files provide almost no information on which tracker was used to save the IT file, so all XMPlay or OpenMPT can do is guess which playback quirks to enable and which not.

Slender

Slender

2019-09-11 08:51

reporter   ~0004060

Yes, there is a panbrello effect on the bongos, instruments 192 to 199.

Saga Musix

Saga Musix

2019-09-11 17:26

administrator   ~0004061

Panbrello is a pattern command (Yxx). You are referring to pan swing.

Anyway, what's happening here is that the original IT file was saved with an earlier version of ModPlug Tracker, and in those versions the pan swing range was four times deeper than it should be. When decoding the MO3 file, OpenMPT correctly deduces that the file was made with such an older MPT version and automatically fixes the pan swing range to a fourth of the values stored in the file; when loading the UNMO3-ed version this is not possible, because we can no longer deduce that the file was made with an early version of MPT. This information is lost in UNMO3's decoding process.

Issue History

Date Modified Username Field Change
2019-09-10 22:37 Slender New Issue
2019-09-11 06:34 Saga Musix Note Added: 0004059
2019-09-11 08:51 Slender Note Added: 0004060
2019-09-11 17:26 Saga Musix Note Added: 0004061
2019-09-11 17:27 Saga Musix Status new => closed
2019-09-11 17:27 Saga Musix Resolution open => no change required