View Issue Details

IDProjectCategoryView StatusLast Update
0001252OpenMPT[All Projects] User Interfacepublic2019-08-22 21:31
ReporterFred57 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.28.06.00 / libopenmpt 0.4.6 (upgrade first) 
Target VersionOpenMPT 1.29 / libopenmpt 0.5 (goals)Fixed in VersionOpenMPT 1.29 / libopenmpt 0.5 (goals) 
Summary0001252: Moving patterns in the order list to the right should insert them right of the target
Description

I have got for example 5 pattern
1 2 3 4 5
If I click on 3 and drag it on 2 I have got 1 3 2 4 5 ! that's fine
If I click on 4 and drag it on 5 there is no action, I need to drag it on the empty position after 5 to do the correct action.
Same thing if I drag one pattern on the middle of the empty patterns, the position is not where the mouse is but one postion before.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-08-14 18:11

administrator   ~0004012

Note that the current behaviour is at least required for duplicating patterns; otherwise shift-dragging a pattern next to itself to duplicate it is not possible. Hence items are always inserted left of the insertion cursor. I'm not a big fan of making it inconsistent between those two edit modes, in particular since it will affect thousands of users that already got used to the current behaviour.

Gerirish

Gerirish

2019-08-14 19:25

reporter   ~0004013

I'm not a big fan of making it inconsistent between those two edit modes, in particular since it will affect thousands of users that already got used to
the current behaviour.

Maybe an option in the settings would help to let user decide what they prefer.

Fred57

Fred57

2019-08-14 20:57

reporter   ~0004014

Shift dragging is not a problem, you can detect if the shift key is pressed or not...
Think of new users, they drag a pattern to a cell, the cell is lightning and an other cell accept the pattern, that's very special ! :)

Saga Musix

Saga Musix

2019-08-14 20:59

administrator   ~0004015

Shift dragging is not a problem, you can detect if the shift key is pressed or not...

Please, don't try to explain to me how to code. Obviously OpenMPT is already checking if the Shift key is pressed this to allow users to duplicate patterns. The point is that shift-dragging requires the current behaviour and only using this behaviour for shift-dragging would make it inconsistent, which would confuse users even more.

Saga Musix

Saga Musix

2019-08-22 21:09

administrator   ~0004017

Okay, I think I found a middle ground. I will use the new behaviour (inserting to the right rather than to the left) in all cases, but there will be a visual indicator making it clear on which side the patterns will be inserted / duplicated. If someone wants to duplicate patterns right next to their original location, there is already the Duplicate Patterns command.

Saga Musix

Saga Musix

2019-08-22 21:31

administrator   ~0004018

r11934 modifies the behaviour as outlined in the previous comment. However, since this is quite a big change for users it will not make it into OpenMPT 1.28; this will be a behavioural change in OpenMPT 1.29. Current OpenMPT 1.29 test builds can be obtained from https://builds.openmpt.org/builds/

Issue History

Date Modified Username Field Change
2019-08-13 20:21 Fred57 New Issue
2019-08-13 20:29 Saga Musix Summary Moving a pattern at a position N give the position N-1 => Moving patterns in the order list to the right should insert them right of the target
2019-08-14 18:11 Saga Musix Note Added: 0004012
2019-08-14 19:25 Gerirish Note Added: 0004013
2019-08-14 20:57 Fred57 Note Added: 0004014
2019-08-14 20:59 Saga Musix Note Added: 0004015
2019-08-22 21:09 Saga Musix Note Added: 0004017
2019-08-22 21:09 Saga Musix Assigned To => Saga Musix
2019-08-22 21:09 Saga Musix Status new => assigned
2019-08-22 21:31 Saga Musix Status assigned => resolved
2019-08-22 21:31 Saga Musix Resolution open => fixed
2019-08-22 21:31 Saga Musix Fixed in Version => OpenMPT 1.29 / libopenmpt 0.5 (goals)
2019-08-22 21:31 Saga Musix Target Version => OpenMPT 1.29 / libopenmpt 0.5 (goals)
2019-08-22 21:31 Saga Musix Note Added: 0004018