View Issue Details

IDProjectCategoryView StatusLast Update
0001229OpenMPT[All Projects] Generalpublic2019-07-11 16:38
ReporterjmkzAssigned To 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionunable to reproduce 
Platformx64OSWindowsOS Version8
Product VersionOpenMPT 1.29.00.* (current testing) 
Target VersionFixed in Version 
Summary0001229: Not yet reproducible crash after closing a song
Description

OpenMPT triggered error catch, this was after closing a song. I can't get happen again but I attached crash files. I also have full dump if needed.

Steps To Reproduce

Not yed reproducible. Happened after closing a song.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)r11629

Activities

jmkz

jmkz

2019-06-08 04:53

reporter  

2019-06-06 23.26.05.7z (37,101 bytes)
Saga Musix

Saga Musix

2019-06-08 09:41

administrator   ~0003961

The crash signature is identical to what this person was experiencing: https://social.msdn.microsoft.com/Forums/sqlserver/en-US/2d6aaf44-8b77-4406-ab34-11bdaf3077b9/crash-in-comctl32dll-in-tvgetitemrect-function?forum=vcgeneral
So it might not even be an OpenMPT-specific bug.

>   comctl32.dll!TV_GetItemRect(struct _TREE *,struct _TREEITEM *,struct tagRECT *,unsigned int)    Unknown
    comctl32.dll!TV_InvalidateItem(struct _TREE *,struct _TREEITEM *,unsigned int)  Unknown
    comctl32.dll!TV_OnMouseMove()   Unknown
    comctl32.dll!TV_WndProc()   Unknown
    mptrack.exe!CWnd::DefWindowProcW(unsigned int nMsg, unsigned int wParam, long lParam) Line 1107 C++
Saga Musix

Saga Musix

2019-07-11 16:38

administrator   ~0003979

Closing as there was no repro case and the code that crashed is in a Windows component

Issue History

Date Modified Username Field Change
2019-06-08 04:53 jmkz New Issue
2019-06-08 04:53 jmkz File Added: 2019-06-06 23.26.05.7z
2019-06-08 09:41 Saga Musix Note Added: 0003961
2019-07-11 16:38 Saga Musix Status new => closed
2019-07-11 16:38 Saga Musix Resolution open => unable to reproduce
2019-07-11 16:38 Saga Musix Note Added: 0003979