View Issue Details

IDProjectCategoryView StatusLast Update
0001228OpenMPT[All Projects] User Interfacepublic2019-06-02 21:06
ReporterStinkerB06Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.05.00 / libopenmpt 0.4.5 (upgrade first) 
Target VersionFixed in Version 
Summary0001228: "Convert existing samples to instruments first?" dialog creates one additional dummy sample.
Description

If you select "Yes" or "No" in the aforementioned pop-up dialog, a new sample gets created out of nowhere.

For example, if your module has 4 samples that occupy sample slots 1~4, and you decide to convert them to instruments, it creates sample slot 5. If you select "Yes", then that 5th sample also gets converted to an instrument.

Steps To Reproduce
  1. Create a new module in any format that supports instruments (MPTM, IT, or XM).
  2. Add some samples to the module. It doesn't matter how many.
  3. Go to the "Instruments" tab and click "New instrument".
  4. In the following dialog, click "Yes" or "No", but not "Cancel".
  5. Go to the "Samples" tab. You'll notice that it automatically created a new sample.
Additional Information

I don't have anything else to say about the bug/issue itself, but I'm not sure what Priority this should be kept at.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-06-02 21:06

administrator   ~0003959

This is by design and not special to this situation - any newly inserted instrument will have an empty sample slot assigned to it. In particular, "Convert existing samples to instrument first?" adds a new instrument, and this new instrument is assigned to an - at this point empty sample slot.

Issue History

Date Modified Username Field Change
2019-06-01 07:48 StinkerB06 New Issue
2019-06-02 21:06 Saga Musix Note Added: 0003959
2019-06-02 21:06 Saga Musix Status new => closed
2019-06-02 21:06 Saga Musix Resolution open => no change required