View Issue Details

IDProjectCategoryView StatusLast Update
0001221OpenMPT[All Projects] Playback Compatibilitypublic2019-05-25 13:01
Reportermrbumpy409Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx86 / x64OSWineOS Version(version plz)
Product VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first) 
Target VersionFixed in Version 
Summary0001221: Amiga resampler output very muffled when playing "Act of Impulse" by Mantronix & Tip
Description

I've noticed that the Amiga 1200 recordings at SOAMC are a bit brighter than playback using OpenMPT's Amiga resampler. I presume this is due to the Amiga resampler being based on the more heavily filtered A500?

That being said, the tune "Act of Impulse" by Mantronix & Tip" plays back particularly muffled in OpenMPT with the Amiga resampler. Here is the SOAMC Amiga 1200 recording to compare. Even OpenMPT's linear resampling is notably brighter. This doesn't seem right to me.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-04-13 15:21

administrator   ~0003919

That is correct, there is currently no way to switch between A500 an A1200 output.

Saga Musix

Saga Musix

2019-04-13 15:24

administrator   ~0003920

The fact that this tune sounds very muffled is due to the extra LED filter being enabled (E02 command at the beginning); it is of course possible and quite likely that this tune was written in a tracker where the E02 command was interpreted differently than it is in ProTracker 2. However it's not really possible to tell which tracker it was written in, so there is nothing we can do about not enabling the LED filter.

mrbumpy409

mrbumpy409

2019-04-13 21:03

reporter   ~0003922

Deleting the E02 command fixes the muffled playback. Thanks for the tip! I had completely forgotten about the Amiga's LED filter.

Issue History

Date Modified Username Field Change
2019-04-13 14:30 mrbumpy409 New Issue
2019-04-13 15:21 Saga Musix Note Added: 0003919
2019-04-13 15:24 Saga Musix Note Added: 0003920
2019-04-13 21:03 mrbumpy409 Note Added: 0003922
2019-05-25 13:01 Saga Musix Status new => closed
2019-05-25 13:01 Saga Musix Resolution open => no change required