View Issue Details

IDProjectCategoryView StatusLast Update
0001215OpenMPT[All Projects] Feature Requestpublic2019-03-11 18:04
ReporterharbingerAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version7
Product Version 
Target VersionFixed in Version 
Summary0001215: Write lossless audio files which ignore silent regions
Description

I would love to see ModPlug store DAW segments, so that a lot of my hard drive or thumbdrive memory isn't wasted recording silent data. Ideally, i'd like to be able to open this audio file directly in Audacity.

You normally find these time-placed audio segments when you trim the silent parts in your DAW (at least i can in Audacity). I'm guessing that Audacity stores only the audio for that track/channel and includes the time shift for that segment somewhere in the saved file, instead of saving huge chunks of zeroes.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0001209 closed Write lossless audio files which ignore silent regions 

Activities

Saga Musix

Saga Musix

2019-03-11 18:04

administrator   ~0003900

As already explained in issue 0001209, none of the formats supported by both OpenMPT and Audacity allow complete omission of silence, however the FLAC format will store silence in a very compact way (100MB of silence can be reduced to just a few hundred KB). Adding support for Audacity's (or any other sample editor's) project file format just to reduce the footprint of exported files is completely out of scope for OpenMPT. The FLAC format should already serve your purpose well enough.

Issue History

Date Modified Username Field Change
2019-03-11 17:57 harbinger New Issue
2019-03-11 18:04 Saga Musix Note Added: 0003900
2019-03-11 18:04 Saga Musix Relationship added duplicate of 0001209
2019-03-11 18:04 Saga Musix Status new => closed
2019-03-11 18:04 Saga Musix Resolution open => duplicate