View Issue Details

IDProjectCategoryView StatusLast Update
0001199OpenMPT[All Projects] Playback Compatibilitypublic2019-02-28 20:54
ReporterSlenderAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.03.00 / libopenmpt 0.4.3 (current stable) 
Target VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upcoming stable)Fixed in VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upcoming stable) 
Summary0001199: A glitch in slow-funk.mod by Drax
Description

In the above module, http://modland.com/pub/modules/Protracker/Drax/slow-funk.mod, at around 0:23 in, there seems to be an incorrect note that plays instead of the bass when played in OpenMPT. Other players such as XMPlay don't seem to do this.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-02-24 11:57

administrator   ~0003857

You will in fact find that the latest test versions of XMPlay will behave the same. This is happening due to on-the-fly sample swapping. The module was probably written in FastTracker 2, which is one of the few widespread MOD-compatible trackers that don't implement this at all. You can disable on-the-fly sample swapping in the song properties in OpenMPT, but it won't get saved to the file, and in libopenmpt-based players there is currently no way to turn it off either. Since other tunes require this behaviour, it's hard to tell heuristically when it should not be applied. Maybe I can come up with an improved heuristic but don't hold your breath. :)

Saga Musix

Saga Musix

2019-02-24 16:52

administrator   ~0003858

I realized that the on-the-fly sample swap detection heuristics was actually bypassed since 0000754 was fixed, so it was applied unconditionally. I have now modified the behaviour to always use on-the-fly sample swapping for Amiga-compatible modules and resort to the heuristic for all other modules (like slow-funk.mod). The new behaviour is available as of r11395. I want to gain some more confidence in this before merging this back into OpenMPT 1.28, so please report if any other MOD files no longer play as intended.

Slender

Slender

2019-02-24 19:18

reporter   ~0003859

So FastTracker 2 allowed you to save four channel Amiga modules with its additions used, similar to ImpulseTracker with S3M?

Saga Musix

Saga Musix

2019-02-24 19:20

administrator   ~0003860

There are no additions, just different interpretation of pattern data - in this particular case, the author entered some bogus instrument numbers without notes next to them into the patterns, which doesn't do anything in FT2 in this particular case, but in fully ProTracker-compatible players, the new instrument is played. FT2 is not the only player doing this, I think ST3 would for example do the same.

Slender

Slender

2019-02-24 19:43

reporter   ~0003861

I still have quite a lot of modules to test, but the ones I've tested so far seem to be behaving normally.

Issue History

Date Modified Username Field Change
2019-02-23 20:14 Slender New Issue
2019-02-24 11:57 Saga Musix Note Added: 0003857
2019-02-24 16:52 Saga Musix Note Added: 0003858
2019-02-24 16:52 Saga Musix Assigned To => Saga Musix
2019-02-24 16:52 Saga Musix Status new => assigned
2019-02-24 16:53 Saga Musix Status assigned => feedback
2019-02-24 19:18 Slender Note Added: 0003859
2019-02-24 19:18 Slender Status feedback => assigned
2019-02-24 19:20 Saga Musix Note Added: 0003860
2019-02-24 19:43 Slender Note Added: 0003861
2019-02-28 20:54 Saga Musix Status assigned => resolved
2019-02-28 20:54 Saga Musix Resolution open => fixed
2019-02-28 20:54 Saga Musix Fixed in Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upcoming stable)
2019-02-28 20:54 Saga Musix Target Version => OpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upcoming stable)