View Issue Details

IDProjectCategoryView StatusLast Update
0001173OpenMPT[All Projects] libopenmptpublic2018-11-24 10:48
ReporterhasporAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.27.11.00 / libopenmpt 0.3.13 (current stable) 
Target VersionOpenMPT 1.28.01.00 (goals)Fixed in VersionOpenMPT 1.28.01.00 (goals) 
Summary0001173: MOD file playing wrong with latest libopenmpt
Description

Difficult to explain the technical details. Listen the attached song and compare it to the youtube link. This is platform-independent issue.

Link below shows how it should be played:
https://www.youtube.com/watch?v=xlVyv7bzTHA

Steps To Reproduce

Just play the attached mod file and within 5 seconds the problem becomes audible.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0000779 new Allow certain playback-related flags to be set as load-time ctl or during playback 

Activities

haspor

haspor

2018-11-24 10:43

reporter  

LHS_MI.zip (3,020 bytes)
Saga Musix

Saga Musix

2018-11-24 10:48

administrator   ~0003738

As I explained on IRC yesterday, this happens because the MOD pattern data is within the Amiga limits, so OpenMPT plays it like ProTracker would. However, I have applied some other heuristics in r10989 which make the file play correctly (it has zero-length loops for unlooped samples, so it wasn't saved in ProTracker and thus ProTracker quirks should not apply).

In the future, to be more easily able to control playback of such troublesome files without adding more heuristics we need to implement 0000779.

Issue History

Date Modified Username Field Change
2018-11-24 10:43 haspor New Issue
2018-11-24 10:43 haspor File Added: LHS_MI.zip
2018-11-24 10:48 Saga Musix Note Added: 0003738
2018-11-24 10:48 Saga Musix Status new => resolved
2018-11-24 10:48 Saga Musix Resolution open => fixed
2018-11-24 10:48 Saga Musix Product Version => OpenMPT 1.27.11.00 / libopenmpt 0.3.13 (current stable)
2018-11-24 10:48 Saga Musix Fixed in Version => OpenMPT 1.28.01.00 (goals)
2018-11-24 10:48 Saga Musix Target Version => OpenMPT 1.28.01.00 (goals)
2018-11-24 10:48 Saga Musix Relationship added related to 0000779