View Issue Details

IDProjectCategoryView StatusLast Update
0001171OpenMPT[All Projects] Playback Compatibilitypublic2018-12-10 19:35
ReporterASIKWUSpulseAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7+
Product VersionOpenMPT 1.27.11.00 / libopenmpt 0.3.13 (current stable) 
Target VersionOpenMPT 1.28.01.00 (goals)Fixed in VersionOpenMPT 1.28.01.00 (goals) 
Summary0001171: Instrument release-node bug
Description

In OpenMPT 1.22, it was possible to create zero-sustain instruments with release:
Release-node is put at value 64 and no matter where you are in the Attack-Decay-Sustain part, the release curve will start from the current envelope-point at key-release.

However, in some version later, the behaviour was changed to improve the release, but using the described technique now will result in the envelope-volume jumping to full volume at release, instead of fading out at the current level where you were.

Steps To Reproduce

Uhm? Issue tracker displays a swedish instruction in this field for me. Not sure how to answer here but:

Try creating a instrument with a fading decay-curve with the bottom-node as the sustain. Then, put another node behind that you toggle as release node, and draw a fading release curve with another zero-node.

Try this in OpenMPT 1.22 and then in the current version. You will notice a difference.

Additional Information

I have a pair of soundsamples of a 1.22-module, played in it's mother-version respective the current version. Please have a listen.

TagsNo tags attached.
Has the bug occurred in previous versions?Yep, not sure which, but kind of between 1.23-1.25ish all the way to the current
Tested code revision (in case you know it)

Relationships

related to 0001176 resolvedSaga Musix Release-node discards sustain-loop 

Activities

ASIKWUSpulse

ASIKWUSpulse

2018-11-23 19:37

reporter  

soundsamples.zip (236,531 bytes)
Saga Musix

Saga Musix

2018-11-23 23:53

administrator   ~0003736

First analysis shows that this happens when using release nodes while the "IT-style envelope position advance + enable/disable behaviour" compatibility flag is enabled.

Saga Musix

Saga Musix

2018-11-23 23:56

administrator   ~0003737

Last edited: 2018-11-23 23:59

View 2 revisions

Bug was introduced in v1.23.01.02 / r4009. Good thing that noone noticed for so long! ;)

ASIKWUSpulse

ASIKWUSpulse

2018-12-06 15:02

reporter   ~0003748

Happy that this bug will be fixed; then it's possible to create multisampled piano-instruments with exponetial release. An example of how you can use this envelope-behaviour :-)

Saga Musix

Saga Musix

2018-12-09 14:57

administrator   ~0003751

This should be fixed in OpenMPT 1.28.00.43 / r11014. Note that the bugfix is not applied to modules saved with a version between 1.23.01.02 and 1.28.00.43, such modules will continue to sound "buggy" (i.e. the same way as those OpenMPT versions did). Modules saved with older or newer OpenMPT versions will sound as intended.

Issue History

Date Modified Username Field Change
2018-11-23 19:37 ASIKWUSpulse New Issue
2018-11-23 19:37 ASIKWUSpulse File Added: soundsamples.zip
2018-11-23 19:41 ASIKWUSpulse Description Updated View Revisions
2018-11-23 19:41 ASIKWUSpulse Steps to Reproduce Updated View Revisions
2018-11-23 19:41 ASIKWUSpulse Has the bug occurred in previous versions? Yep, not sure which, but kind of between 1.23-1.25ish => Yep, not sure which, but kind of between 1.23-1.25ish all the way to the current
2018-11-23 23:47 Saga Musix Assigned To => Saga Musix
2018-11-23 23:47 Saga Musix Status new => assigned
2018-11-23 23:53 Saga Musix Note Added: 0003736
2018-11-23 23:56 Saga Musix Note Added: 0003737
2018-11-23 23:59 Saga Musix Note Edited: 0003737 View Revisions
2018-11-24 00:18 Saga Musix Target Version => OpenMPT 1.28.01.00 (goals)
2018-12-06 15:02 ASIKWUSpulse Note Added: 0003748
2018-12-09 14:57 Saga Musix Note Added: 0003751
2018-12-09 14:57 Saga Musix Status assigned => resolved
2018-12-09 14:57 Saga Musix Resolution open => fixed
2018-12-09 14:57 Saga Musix Fixed in Version => OpenMPT 1.28.01.00 (goals)
2018-12-10 19:35 Saga Musix Relationship added related to 0001176