View Issue Details

IDProjectCategoryView StatusLast Update
0001144OpenMPT[All Projects] libopenmptpublic2018-09-15 09:12
ReporterSlenderAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionopen 
Product VersionOpenMPT 1.28.00.* (current testing) 
Target VersionOpenMPT 1.28.01.00 (goals)Fixed in Version 
Summary0001144: SoundFX and OctaMed modules not displaying tracker info in latest revision
Description

Tested with foo_openmpt. It seems that in the latest revision, OctaMed and SoundFX are not returning any info on the tracker used to create them. Example files. ftp://ftp.modland.com/pub/modules/SoundFX/Jean%20Baudlot/operation%20stealth%20-%20bond10.sfx
ftp://ftp.modland.com/pub/modules/OctaMED%20MMD1/Hoffman/hidden%20treasures.mmd1
I'm not sure if this affects other formats, but it doesn't seem like it does. Update. It seems like several other formats are broken, FAR, AMF (both Asylum and DSMI), PSM, IMF and probably several others.

Additional Information

The issue seems to have started somewhere around r10775, though it may have happened earlier.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)r10788

Activities

Saga Musix

Saga Musix

2018-09-15 07:45

administrator   ~0003631

In the case of MED, it's a typo that needs to be fixed. In the case of SFX, we do not have any "made with tracker" information, so only the format type "SoundFX" or "SoundFX 2 / MultiMedia Sound" is filled in now. If we had a way to distinguish e.g. SFX2 from MMS , we could populate the "made with tracker" field more meaningfully, but right now it doesn't make a lot of sense.

Slender

Slender

2018-09-15 08:06

reporter   ~0003632

Does this apply to the other formats affected? PSM, IMF, AMF etc?

Saga Musix

Saga Musix

2018-09-15 08:15

administrator   ~0003635

It applies to several formats, yes. We now have a better way of separating format name and tracker name, so this is now done in a more consistent way.

Slender

Slender

2018-09-15 08:18

reporter   ~0003636

Just for clarification, does this mean the missing tracker field for all formats affected, except for OctaMed, is intentional?

Saga Musix

Saga Musix

2018-09-15 08:43

administrator   ~0003637

Yes, because, as said, the "format" field already contains exactly the same information. You just need to look at a different field. The fact that this information was previously shown also in the "made with tracker" field rather than the "format type" field can be considered a semantic bug.

Saga Musix

Saga Musix

2018-09-15 08:45

administrator   ~0003638

Anyway, r10789 fixes the issue for OctaMED files.

Issue History

Date Modified Username Field Change
2018-09-15 00:00 Slender New Issue
2018-09-15 03:46 Slender Summary SoundFX and OctaMed not displaying tracker info in latest revision => 0SoundFX and OctaMed modules not displaying tracker info in latest revision
2018-09-15 03:46 Slender Summary 0SoundFX and OctaMed modules not displaying tracker info in latest revision => SoundFX and OctaMed modules not displaying tracker info in latest revision
2018-09-15 04:42 Slender Description Updated View Revisions
2018-09-15 04:43 Slender Description Updated View Revisions
2018-09-15 07:41 Saga Musix Assigned To => Saga Musix
2018-09-15 07:41 Saga Musix Status new => assigned
2018-09-15 07:45 Saga Musix Note Added: 0003631
2018-09-15 08:06 Slender Note Added: 0003632
2018-09-15 08:15 Saga Musix Note Added: 0003635
2018-09-15 08:18 Slender Note Added: 0003636
2018-09-15 08:43 Saga Musix Note Added: 0003637
2018-09-15 08:45 Saga Musix Note Added: 0003638
2018-09-15 09:12 Saga Musix Status assigned => resolved
2018-09-15 09:12 Saga Musix Product Version => OpenMPT 1.28.00.* (current testing)
2018-09-15 09:12 Saga Musix Target Version => OpenMPT 1.28.01.00 (goals)