View Issue Details

IDProjectCategoryView StatusLast Update
0001142OpenMPT[All Projects] Generalpublic2018-09-10 19:53
ReporterLPChipAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.09.00 / libopenmpt 0.3.11 (upgrade first) 
Target VersionOpenMPT 1.27.10.00 / libopenmpt 0.3.12 (upgrade first)Fixed in VersionOpenMPT 1.27.10.00 / libopenmpt 0.3.12 (upgrade first) 
Summary0001142: Cursor position wrong after block selection, then cell selection with "always center active row" disabled
Description

When you make a block selection with the mouse, if you then click a cell inside that block selection, that cell is visually selected, but the actual cursor has not moved to that cell, but in fact remains at the bottom right of your block selection.

Steps To Reproduce

Make a selection, for example the first 10 rows, then click on the first row of that selection, then move the cursor down. The cursor is now one row below the selection at the far right of your selection.

Additional Information

Does not happen if you click outside of the selection, but it is very annoying because I often work on that selection, then want to jump to the start of that selection to press F7 to play from that position, but instead it it continues playing after the selection.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-09-10 17:26

administrator   ~0003616

Can't reproduce this, neither in the latest 1.28 test builds nor stable builds. Cursor key navigation is always bound to the one and only cursor position that is also being used when clicking into a selection.

Saga Musix

Saga Musix

2018-09-10 17:36

administrator   ~0003618

Only reproducable with "always center active row" disabled, and it's not even a new issue.

Saga Musix

Saga Musix

2018-09-10 19:51

administrator   ~0003619

Fixed in r10763. For the record, this behaviour has been broken since at least v1.17.02.41. 1.17RC2 still worked as intended.

Issue History

Date Modified Username Field Change
2018-09-10 12:54 LPChip New Issue
2018-09-10 17:26 Saga Musix Note Added: 0003616
2018-09-10 17:27 Saga Musix Severity major => minor
2018-09-10 17:27 Saga Musix Reproducibility always => unable to reproduce
2018-09-10 17:32 LPChip File Added: OpenMPT.7z
2018-09-10 17:36 Saga Musix Note Added: 0003618
2018-09-10 17:37 Saga Musix Reproducibility unable to reproduce => always
2018-09-10 17:37 Saga Musix Product Version OpenMPT 1.28.00.* (current testing) => OpenMPT 1.27.09.00 / libopenmpt 0.3.11 (upgrade first)
2018-09-10 17:37 Saga Musix Summary Player position wrong after block selection, then cell selection => Cursor position wrong after block selection, then cell selection with "always center active row" disabled
2018-09-10 18:10 Saga Musix Assigned To => Saga Musix
2018-09-10 18:10 Saga Musix Status new => assigned
2018-09-10 19:23 Saga Musix File Deleted: OpenMPT.7z
2018-09-10 19:51 Saga Musix Note Added: 0003619
2018-09-10 19:53 Saga Musix Status assigned => resolved
2018-09-10 19:53 Saga Musix Resolution open => fixed
2018-09-10 19:53 Saga Musix Fixed in Version => OpenMPT 1.27.10.00 / libopenmpt 0.3.12 (upgrade first)
2018-09-10 19:53 Saga Musix Target Version => OpenMPT 1.27.10.00 / libopenmpt 0.3.12 (upgrade first)