View Issue Details

IDProjectCategoryView StatusLast Update
0001139OpenMPTPlugins / VSTpublic2018-08-20 11:53
ReporterMonsterovich Assigned To 
PrioritynormalSeverityfeatureReproducibilitysometimes
Status closedResolutionduplicate 
Platformx86 / x64OSWineOS Version(version plz)
Summary0001139: Visual node editor for VST plugins
Description

I think it'd be cool if we had something more convenient for binding VST plugins than lists. (see attachments) Such feature should simplify and perhaps expand the use of VST plugins in OpenMPT. I've seen node editors in other digital software such as Natron where it's used to connect graphical effects. (https://media.blendernation.com/wp-content/uploads/2014/06/Screen-Shot-2014-05-27-at-5.28.58-PM.png)

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000701 assignedSaga Musix Move plugin settings to separate tab, add modular view 

Activities

Monsterovich

Monsterovich

2018-08-19 22:16

reporter  

node_editor.png (52,478 bytes)   
node_editor.png (52,478 bytes)   
Monsterovich

Monsterovich

2018-08-20 10:31

reporter   ~0003603

Please don't close this issue. 0000701 doesn't represent anything I suggested here.

Saga Musix

Saga Musix

2018-08-20 11:53

administrator   ~0003604

"the lower part will be a visual representation of the plugin routing graph à la Buzz." is exactly what you describe in this issue.

Issue History

Date Modified Username Field Change
2018-08-19 22:16 Monsterovich New Issue
2018-08-19 22:16 Monsterovich File Added: node_editor.png
2018-08-20 07:10 Saga Musix Relationship added duplicate of 0000701
2018-08-20 07:10 Saga Musix Status new => closed
2018-08-20 07:10 Saga Musix Resolution open => duplicate
2018-08-20 10:31 Monsterovich Status closed => feedback
2018-08-20 10:31 Monsterovich Resolution duplicate => reopened
2018-08-20 10:31 Monsterovich Note Added: 0003603
2018-08-20 11:53 Saga Musix Note Added: 0003604
2018-08-20 11:53 Saga Musix Status feedback => closed
2018-08-20 11:53 Saga Musix Resolution reopened => duplicate