View Issue Details

IDProjectCategoryView StatusLast Update
0001124OpenMPT[All Projects] Plugins / VSTpublic2018-05-30 18:38
ReporterblimeyAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx86OSWindowsOS Version10
Product VersionOpenMPT 1.27.08.00 / libopenmpt 0.3.9 (current stable) 
Target VersionFixed in Version 
Summary0001124: VSTs not reset/flushed when using 'Export as Lossless/Lossy'
Description

If you're exporting your module, any VSTs used during playback should have their output buffers flushed / be reset.

Steps To Reproduce
  • Create/Load a mod
  • Add a reverb / echo VST on a channel
  • Play the mod, so channel with reverb / echo is triggered
  • Press stop
  • Export as Lossess
  • Note that the reverb / echo from playback can still be heard on the beginning of the exported file
Additional Information

Same kind of problem happens when pressing stop and then play.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-05-30 18:38

administrator   ~0003539

This is an issue with non-standard plugins which do not reset their effect tails when told to do so. You can work around this by checking the "clear plugin buffers before exporting" in the export dialog.

Issue History

Date Modified Username Field Change
2018-05-30 18:36 blimey New Issue
2018-05-30 18:38 Saga Musix Status new => closed
2018-05-30 18:38 Saga Musix Resolution open => no change required
2018-05-30 18:38 Saga Musix Note Added: 0003539