View Issue Details

IDProjectCategoryView StatusLast Update
0001078OpenMPTlibopenmptpublic2018-01-17 12:15
Reporterjimbo1qaz Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.03.00 / libopenmpt 0.3.4 (upgrade first) 
Summary0001078: Silent audio output (no sound) on foobar2000
Description

When I play the demo mptm files in foobar2000, no audio is produced.

I've tested with both 0.3.4 (https://lib.openmpt.org/libopenmpt/download/ ) and foobar2000's automatic upgrade 0.4.0-pre.3+3 (https://www.foobar2000.org/components/view/foo_openmpt ).

(Is the foobar2000 port maintained by kode54 or openmpt?)

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000925 newmanx Support for external samples in libopenmpt 

Activities

jimbo1qaz

jimbo1qaz

2018-01-17 07:25

reporter   ~0003392

Only Geekodelic Fantasy and Gametheme have partial output. It seems like all non-embedded samples can't be loaded properly.

manx

manx

2018-01-17 08:04

administrator   ~0003393

The demo files currently shipped with OpenMPT use external samples, which are not supported by libopenmpt (and therefore by foo_openmpt) as of now.
Which is the reason we do not actually ship these demo files with libopenmpt at all.
Using external samples is not recommended for distributing modules, and as currently no known player supports this, there are probably none available in the wild (short of the OpenMPT demo files).

manx

manx

2018-01-17 08:05

administrator   ~0003394

(Is the foobar2000 port maintained by kode54 or openmpt?)

Sadly, that situation is currently a mess. I will have to add a news/FAQ entry to the libopenmpt website about the confusion soonish,

Saga Musix

Saga Musix

2018-01-17 12:14

administrator   ~0003395

As manx says, external samples are not supported by libopenmpt, but you can resave the files with embedded samples instead.

Issue History

Date Modified Username Field Change
2018-01-17 07:10 jimbo1qaz New Issue
2018-01-17 07:25 jimbo1qaz Note Added: 0003392
2018-01-17 08:04 manx Note Added: 0003393
2018-01-17 08:05 manx Note Added: 0003394
2018-01-17 08:06 manx Relationship added duplicate of 0000925
2018-01-17 12:14 Saga Musix Note Added: 0003395
2018-01-17 12:15 Saga Musix Status new => closed
2018-01-17 12:15 Saga Musix Resolution open => duplicate