View Issue Details

IDProjectCategoryView StatusLast Update
0001075OpenMPT[All Projects] Plugins / VSTpublic2018-01-10 20:46
ReporterchokoAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.03.00 / libopenmpt 0.3.4 (current stable) 
Target VersionFixed in Version 
Summary0001075: Element Plugin loads everytime playback is started.
Description

I've talked to the developer of Element and this is what he observed:

"Basically what's happening is OpenMP stops its entire audio engine (closes the audio device) when stop is pressed. Because of this Element (and every other plugin) gets fully deactivated. Then, when you press play, the audio device is opened and all the plugins are activated again."

I've checked all the audio devices I have listed, but none allow the audio device to stay on when playback is stopped.

Every time I hit play, it decides to load all the instruments and effects within Element (up to 20 second loading every time I hit play).

The developer of Element is interested in what you have to say.

Thanks for reading!

Additional Information

https://kushview.net/element/

Example of the issue (Piano is hosted in Element):
https://www.dropbox.com/s/xreejazqban48c2/OpenMPT%201.27.03.00%20-%20%5Belement.mptm%5D%201_9_2018%206_38_58%20PM.mp4?dl=0

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

choko

choko

2018-01-10 03:34

reporter   ~0003388

The developer was sure this was an OpenMPT specific issue... Turns out Reaper is having the same problems! Sorry about the false alarm guys!

Saga Musix

Saga Musix

2018-01-10 12:43

administrator   ~0003389

Last edited: 2018-01-10 12:52

View 2 revisions

A VST host is allowed to stop and resume playback of VST plugins at any time it wishes. If the plugin developer decides to reload its settings when playback is resumed, that's a fault of the plugin. I'll try to get in touch with the developer.

choko

choko

2018-01-10 20:45

reporter   ~0003390

This is solved now.

Developer describing the problem:
"So basically Element, in the plugin version, caches the number of ins/out busses so that it doesn't reload itself all of the time (yeah... I know). Turns out, some of these hosts do things slightly different when stop/play happens and those io counts were not cached"

Saga Musix

Saga Musix

2018-01-10 20:46

administrator   ~0003391

Good to know. :)

Issue History

Date Modified Username Field Change
2018-01-10 01:16 choko New Issue
2018-01-10 03:34 choko Note Added: 0003388
2018-01-10 12:43 Saga Musix Note Added: 0003389
2018-01-10 12:52 Saga Musix Note Edited: 0003389 View Revisions
2018-01-10 17:48 Saga Musix View Status private => public
2018-01-10 20:45 choko Note Added: 0003390
2018-01-10 20:46 Saga Musix Note Added: 0003391
2018-01-10 20:46 Saga Musix Status new => resolved
2018-01-10 20:46 Saga Musix Resolution open => no change required