View Issue Details

IDProjectCategoryView StatusLast Update
0001068OpenMPT[All Projects] Plugins / VSTpublic2017-11-27 19:38
ReporterharbingerAssigned To 
PrioritynormalSeveritytrivialReproducibilityalways
Status newResolutionopen 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Target VersionFixed in Version 
Summary0001068: Amplify/Undo during Playback with M1 1.0
Description

Found an extremely minor bug while creating a track with my M1. When you undo an "Amplify From" function (the straight Amplify is fine) DURING PLAYBACK, the display changes but the volume does not return to the original. The only way to return to the shown volume is to click the Panic button or stop/start playback.
In itself it's minor, because the resolution is easy. But the "faulty" code may contribute to other problems that may show themselves later.

I have a feeling it's a problem with the M1 plugin because other plugins i tried worked fine when undoing the scaled Amplify during playback.

Steps To Reproduce
  1. Create M1-based series of notes in a channel with Default Volume of 64. Play this pattern in a loop.
  2. Call the Amplify dialog and amplify from say 50% to 80% as it's playing. Works fine.
  3. Call your Undo shortcut. The display shows the previous 64s in the volume columns but the audio is not at full (depending on where you called the Undo).
  4. While it's playing, click the Panic button in the transport window. The audio is reverted and plays properly.
TagsNo tags attached.
Has the bug occurred in previous versions?No, feature wasn't available
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-11-27 19:36

administrator   ~0003365

This sounds like you have "volume command handling" set to "MIDI volume" for that particular instrument, and you have volume commands "between" notes. In this case, the MIDI volume on that channel will not be updated until OpenMPT reaches another place where the MIDI channel volume is being set. Since MIDI CC status is not exposed by plugins, OpenMPT has no way of knowing what the current MIDI CC value is at the current playback position or what it should be. This is true for any plugin, not just M1, and there is no way to fix this.

Saga Musix

Saga Musix

2017-11-27 19:38

administrator   ~0003366

By the way, you really should be updating to M1 1.7.0 as available from korguser.net, as we have already found out in a previous bug report, the older version has bugs that can affect usage in OpenMPT.

Issue History

Date Modified Username Field Change
2017-11-27 19:31 harbinger New Issue
2017-11-27 19:36 Saga Musix Note Added: 0003365
2017-11-27 19:38 Saga Musix Note Added: 0003366