View Issue Details

IDProjectCategoryView StatusLast Update
0001066OpenMPT[All Projects] User Interfacepublic2017-11-23 01:33
ReporterDustBoxedAssigned To 
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (current stable) 
Target VersionFixed in Version 
Summary0001066: Optimization for 1920 x 1080 displays
Description

I've noticed that OpenMPT turns out a bit blurry on my new laptop's screen, and its really ugly. The problem is only fixed when increasing the size of on-screen elements in the Windows 10 settings, however. But I don't want to have every element on my screen blown up huge just to use OpenMPT, while making it feel good on my eyes as well.

Just in case, here is a screenshot http://hostthenpost.org/uploads/afbafd58ada020bcb1e24a6e104b0208.png

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000627 assignedSaga Musix Make OpenMPT completely DPI-aware 

Activities

Saga Musix

Saga Musix

2017-11-23 01:31

administrator   ~0003356

Last edited: 2017-11-23 01:33

View 4 revisions

This has nothing to do with the screen resolution but with the screen pixel density. You appear to have a high-DPI screen, or at least have configured Windows to use a high DPI, so it has to upscale applications that are not DPI-aware. OpenMPT can be configured to be DPI-aware (see Display.HighResUI option), but currently the icons and a few other GUI items will look too small then. Many VST plugins also have problems with high-DPI screens, which is another reason why this setting is not enabled by default.

Issue History

Date Modified Username Field Change
2017-11-22 23:42 DustBoxed New Issue
2017-11-22 23:45 DustBoxed Description Updated View Revisions
2017-11-23 01:31 Saga Musix Note Added: 0003356
2017-11-23 01:32 Saga Musix Note Edited: 0003356 View Revisions
2017-11-23 01:32 Saga Musix Relationship added duplicate of 0000627
2017-11-23 01:32 Saga Musix Status new => closed
2017-11-23 01:32 Saga Musix Resolution open => duplicate
2017-11-23 01:33 Saga Musix Note Edited: 0003356 View Revisions
2017-11-23 01:33 Saga Musix Note Edited: 0003356 View Revisions