View Issue Details

IDProjectCategoryView StatusLast Update
0001056OpenMPT[All Projects] User Interfacepublic2017-12-15 18:05
ReporterblimeyAssigned ToSaga Musix 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (upgrade first) 
Target VersionOpenMPT 1.27.03.00 / libopenmpt 0.3.4 (upgrade first)Fixed in VersionOpenMPT 1.27.03.00 / libopenmpt 0.3.4 (upgrade first) 
Summary0001056: Spinner for "Restart Position" can get stuck when patterns are deleted
Description

Deleting patterns can break the spinner used to increment/decrement the restart pattern number.

Steps To Reproduce

Make a new module (File -> New -> OpenMPT Module)
Create a second pattern, (Right click and choose "Create New Pattern)
Set the "Restart Position" to 1 (to refer to the second pattern)
Remove either of the patterns
Note the "Restart Position" is still 1, although the highest possible value is 0
Try using the down arrow on the spinner to change the "Restart Position" back to 0, and nothing happens
Can only correct the "Restart Position" by keying in the number

TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-11-11 13:54

administrator   ~0003328

Fixed in r9252, soon available for testing at https://builds.openmpt.org/builds/index.html

Saga Musix

Saga Musix

2017-11-21 00:04

administrator   ~0003354

It would be great if you could confirm whether this and the other reported issues have been fixed in the testing version.

blimey

blimey

2017-11-30 19:46

reporter   ~0003368

Tested in 1.28.00.04. Spinner does not get stuck when following test steps.

It does seems as though the valid range for the restart position is based on the highest value used, so the following is possible:

  • Create a sequence of patterns 0 1 2
  • Set restart point to 2
  • Remove patterns 1 and 2 from the sequence
  • Change restart point to 0
  • Click up on the spinner, and you can still select position 1 or 2

Clicking up on the spinner should probably do nothing if it would result in a value that's higher than the position of the last current pattern.

Saga Musix

Saga Musix

2017-12-15 18:05

administrator   ~0003385

It's even easier than that - you could just manually input a high enough number (provided that the order list grew big enough previously). I have no intention to "fix" that though, since technically there is nothing that's really broken.

Issue History

Date Modified Username Field Change
2017-11-08 21:39 blimey New Issue
2017-11-08 23:28 Saga Musix Assigned To => Saga Musix
2017-11-08 23:28 Saga Musix Status new => assigned
2017-11-11 13:53 Saga Musix Status assigned => feedback
2017-11-11 13:53 Saga Musix Target Version => OpenMPT 1.27.03.00 / libopenmpt 0.3.4 (upgrade first)
2017-11-11 13:54 Saga Musix Note Added: 0003328
2017-11-21 00:04 Saga Musix Note Added: 0003354
2017-11-30 19:46 blimey Note Added: 0003368
2017-11-30 19:46 blimey Status feedback => assigned
2017-12-15 18:05 Saga Musix Status assigned => resolved
2017-12-15 18:05 Saga Musix Resolution open => fixed
2017-12-15 18:05 Saga Musix Fixed in Version => OpenMPT 1.27.03.00 / libopenmpt 0.3.4 (upgrade first)
2017-12-15 18:05 Saga Musix Note Added: 0003385