View Issue Details

IDProjectCategoryView StatusLast Update
0001046OpenMPT[All Projects] libopenmptpublic2018-03-02 20:13
ReportermanxAssigned Tomanx 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Versionlibopenmpt 0.4 (goals)Fixed in Versionlibopenmpt 0.4 (goals) 
Summary0001046: Support libc++ in Android builds
Description

Android NDK 16 changed the recommended default from gnustl_shared to libc++_shared.
Make sure libopenmpt works and implement the required build system changes.

This might imply deprecating all previous Android NDK versions for libopenmpt.

Additional Information

https://developer.android.com/ndk/guides/cpp-support.html
https://developer.android.com/ndk/downloads/revision_history.html

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0001051 resolvedmanx libopenmpt C interface android compile error 

Activities

manx

manx

2017-10-28 14:09

administrator   ~0003319

Looks like there is no way to query the NDK version from within ndk-build (which is incredibly stupid), so we cannot switch between gnustl_shared and c++_shared.

Switching to c++_shared is trivial, already works with NDK 16-beta1.

manx

manx

2018-03-02 20:13

administrator   ~0003453

r9817

Issue History

Date Modified Username Field Change
2017-10-19 11:10 manx New Issue
2017-10-19 11:10 manx Status new => assigned
2017-10-19 11:10 manx Assigned To => manx
2017-10-25 11:38 manx Relationship added related to 0001051
2017-10-28 14:09 manx Note Added: 0003319
2018-03-02 20:13 manx Status assigned => resolved
2018-03-02 20:13 manx Resolution open => fixed
2018-03-02 20:13 manx Fixed in Version => libopenmpt 0.4 (goals)
2018-03-02 20:13 manx Note Added: 0003453