View Issue Details

IDProjectCategoryView StatusLast Update
0001035OpenMPT[All Projects] Plugins / VSTpublic2017-09-27 21:22
ReporterchokoAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Target VersionFixed in Version 
Summary0001035: Synth1 error when in poly mode
Description

Synth1 throws an error when in poly mode for any instrument.

"The plugin threw an exception (C0000005) in processReplacing. It has automatically been set to "Bypass". (Plugin=Synth1 VST64)"

EDIT: It appears it has to be poly and not unison for this to work. Poly works fine when unison is on.

Steps To Reproduce

Make new module (mptm in my case) select any instrument with poly.

Additional Information

I saw an issue with Synth1 was recently solved. This seems different.

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Relationships

duplicate of 0001030 resolvedmanx VSTi Synth1 64bit crashes / not working 

Activities

Saga Musix

Saga Musix

2017-09-27 21:22

administrator   ~0003270

No, it's exactly the same issue. The 64-bit version of Synth1 is buggy, so it has to be either run in the plugin bridge, or you need to use the 32-bit version.
I know it used to work without the plugin bridge previously but that was simply because OpenMPT used less secure ASLR settings in previous versions.

Issue History

Date Modified Username Field Change
2017-09-27 20:37 choko New Issue
2017-09-27 20:52 choko Description Updated View Revisions
2017-09-27 21:21 Saga Musix Relationship added duplicate of 0001030
2017-09-27 21:22 Saga Musix Status new => closed
2017-09-27 21:22 Saga Musix Resolution open => duplicate
2017-09-27 21:22 Saga Musix Note Added: 0003270