View Issue Details

IDProjectCategoryView StatusLast Update
0001022OpenMPT[All Projects] User Interfacepublic2017-09-07 09:46
ReporterjmkzAssigned To 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionunable to reproduce 
Product VersionOpenMPT 1.27.00.* (current testing) 
Target VersionFixed in Version 
Summary0001022: Can not manually assign a value to some VST values
Description

Just noticed that you can not set a custom value throug textbox to non GUI effects.

Steps To Reproduce

Load a plugin with no GUI and try to enter various values in text box, does not parse text input correctly. Tested with DX Echo and Freeverb.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)r8852

Activities

Saga Musix

Saga Musix

2017-09-02 20:00

administrator   ~0003209

I assume you mean the value input on the general tab. Maybe there is a misunderstanding how to input a value there - it has to be input as number between 0 and 1, which is not necessarily the same as the value that is displayed when the edit field is not focussed.

jmkz

jmkz

2017-09-03 06:40

reporter   ~0003210

Sorry for the confussion, I mean throug plugin editor window. See the attached image.



2887910828.png (27,995 bytes)
2887910828.png (27,995 bytes)
Saga Musix

Saga Musix

2017-09-03 10:26

administrator   ~0003211

Last edited: 2017-09-03 10:27

View 2 revisions

That too works just fine here. Inputting a random number in [0,1000] updates the sliders and the effect is audible instantly. Tested both 32-bit and 64-bit binaries.

jmkz

jmkz

2017-09-07 01:13

reporter   ~0003213

I've tested on another PC and this issue doesn't happen with buildbot builds (I was using my portable OpenMPT). Meanwhile, you can close this issue. If I can isolate or replicate, I'll reopen or report something more specific.

Saga Musix

Saga Musix

2017-09-07 09:46

administrator   ~0003214

Please always verify the bugs you want to report against official release and buildbot builds, as we cannot debug personal builds with possible modifications.

Issue History

Date Modified Username Field Change
2017-09-02 15:56 jmkz New Issue
2017-09-02 20:00 Saga Musix Note Added: 0003209
2017-09-02 20:00 Saga Musix Reproducibility always => unable to reproduce
2017-09-03 06:40 jmkz File Added: 2887910828.png
2017-09-03 06:40 jmkz Note Added: 0003210
2017-09-03 10:26 Saga Musix Note Added: 0003211
2017-09-03 10:27 Saga Musix Note Edited: 0003211 View Revisions
2017-09-07 01:13 jmkz Note Added: 0003213
2017-09-07 09:46 Saga Musix Status new => closed
2017-09-07 09:46 Saga Musix Resolution open => unable to reproduce
2017-09-07 09:46 Saga Musix Note Added: 0003214