View Issue Details

IDProjectCategoryView StatusLast Update
0001008OpenMPT[All Projects] Audio I/Opublic2017-08-11 11:03
ReporterPiotrAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first) 
Target VersionFixed in Version 
Summary0001008: Transitions between perfect length samples are unsmooth (default)
Description

At default settings, volume ramping down is longer than up. Therefore there is slight bump in waveform if combined.

http://i.imgur.com/gz7DBVp.png

This is your fault for using these default settings.

Steps To Reproduce

Make tempo for example 4 rows per second, and sample 1/4 seconds long that loops perfectly.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)1.26.12.00

Activities

Saga Musix

Saga Musix

2017-08-11 11:03

administrator   ~0003157

This is by design and you are just scratching the boundaries of what can be done with a reasonably fast resampler with your resampling bug reports. OpenMPT is not a tool for analytical precision.

Issue History

Date Modified Username Field Change
2017-08-11 08:23 Piotr New Issue
2017-08-11 08:24 Piotr Severity minor => tweak
2017-08-11 11:03 Saga Musix Status new => closed
2017-08-11 11:03 Saga Musix Resolution open => no change required
2017-08-11 11:03 Saga Musix Note Added: 0003157