View Issue Details

IDProjectCategoryView StatusLast Update
0000988OpenMPT[All Projects] User Interfacepublic2017-07-15 11:23
ReporterjmkzAssigned Tomanx 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.27.00.* (current testing) 
Target VersionOpenMPT 1.27.01.00 (upcoming stable)Fixed in VersionOpenMPT 1.27.00.* (current testing) 
Summary0000988: Saving song with different name does no update song's name in tree view
Description

When saving a module under other name than original, the song's name does not get updated after save.

Steps To Reproduce

Save a song with any other name and notice that is not updated in treeview

Additional Information

Introduced since r8518

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Activities

manx

manx

2017-07-15 11:23

administrator   ~0003107

Thanks for the report. This was a rather serious bug as it could also cause a ton of other weird and unexpected behavior around file saving. Fixed in 1.27.00.55 / r8531.

Issue History

Date Modified Username Field Change
2017-07-15 07:56 jmkz New Issue
2017-07-15 10:03 manx Status new => confirmed
2017-07-15 10:03 manx Target Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-07-15 10:25 manx Assigned To => manx
2017-07-15 10:25 manx Status confirmed => assigned
2017-07-15 11:23 manx Status assigned => resolved
2017-07-15 11:23 manx Resolution open => fixed
2017-07-15 11:23 manx Fixed in Version => OpenMPT 1.27.00.* (current testing)
2017-07-15 11:23 manx Note Added: 0003107