View Issue Details

IDProjectCategoryView StatusLast Update
0000961OpenMPTPlayback Compatibilitypublic2021-06-03 20:37
Reporterpigdevil2010 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.11.00 / libopenmpt 0.2-beta24 (upgrade first) 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0000961: S3M computed period has no upper bound
Description

This came into my attention when I tried to play an st3 module made in OpenMPT which uses 2 samples long note and noticed that it's played incorrectly in Scream Tracker 3.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

pigdevil2010

pigdevil2010

2017-05-29 13:10

reporter  

PeriodLimit-Upper.zip (33,724 bytes)
Saga Musix

Saga Musix

2017-05-29 16:37

administrator   ~0003040

It's not that simple sadly; you will notice that your test cases will also fail in ST3 when using GUS playback.

Saga Musix

Saga Musix

2021-06-03 17:33

administrator   ~0004781

Last edited: 2021-06-03 19:37

Today I found out that there's a way to detect if an S3M file was last saved with the GUS driver loaded or the SB driver; this makes it more probable that we can have a fix for this specifically for files saved with the SB driver.

Saga Musix

Saga Musix

2021-06-03 19:36

administrator   ~0004783

Implemented in r15258 for modules that are identified to be last saved with the SoundBlaster driver. Please note that this behaviour will not be enforced for S3Ms saved with other trackers, or with S3Ms last saved with the GUS driver.

Saga Musix

Saga Musix

2021-06-03 20:37

administrator   ~0004784

I studied this test case a bit more and it turns out that the GUS also limits the upper period, however its frequency resolution is too low at these high periods, which explains why it sounds very different. So I will enable the period limits also for S3Ms saved with the GUS driver, but the low GUS frequency resolution will not be emulated for now.

Issue History

Date Modified Username Field Change
2017-05-29 13:10 pigdevil2010 New Issue
2017-05-29 13:10 pigdevil2010 File Added: PeriodLimit-Upper.zip
2017-05-29 16:37 Saga Musix Note Added: 0003040
2021-06-03 17:33 Saga Musix Note Added: 0004781
2021-06-03 19:32 Saga Musix Assigned To => Saga Musix
2021-06-03 19:32 Saga Musix Status new => assigned
2021-06-03 19:36 Saga Musix Note Added: 0004783
2021-06-03 19:36 Saga Musix Status assigned => resolved
2021-06-03 19:36 Saga Musix Resolution open => fixed
2021-06-03 19:36 Saga Musix Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-06-03 19:36 Saga Musix Target Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-06-03 19:37 Saga Musix Note Edited: 0004781
2021-06-03 20:37 Saga Musix Note Added: 0004784