View Issue Details

IDProjectCategoryView StatusLast Update
0000840OpenMPT[All Projects] Feature Requestpublic2017-09-24 07:25
ReportermanxAssigned Tomanx 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.26.03.* (old testing) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)Fixed in VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable) 
Summary0000840: Remove underline code comments
Description

//----------- and //========== are used throughout the code base to underline function and class definitions.
Modern code formatting tools like clang-format are not aware of this custom coding convention and are not able to cope with this properly.
Additionally, ==== is the conflict marker used by classic patch, which makes searching for conflict markers unnecessarily difficult.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

manx

manx

2017-08-22 12:05

administrator   ~0003188

find common soundbase soundlib sounddsp sounddev unarchiver mptrack pluginBridge -type f \( -name "*.cpp" -or -name "*.h" -or -name "*.c" \) | xargs -n 1 --no-run-if-empty -I{} bash -c 'sed -i "/^\t* *\/\/--*$/d" {} ; sed -i "/^\t* *\/\/==*$/d" {} '
find README.md | xargs -n 1 --no-run-if-empty -I{} bash -c 'sed -i "/^\t* *\/\/--*$/d" {} ; sed -i "/^\t* *\/\/==*$/d" {} '
manx

manx

2017-08-22 12:10

administrator   ~0003189

We should do that transformation right before making a branch. That way, merges between trunk and the branch will have no conflicts caused by this change.
Applying right after a branch, i.e. when starting a new development version would severely hinder back-porting changes to the previous release branch.

manx

manx

2017-09-24 07:21

administrator   ~0003239

find common soundbase soundlib sounddsp sounddev unarchiver mptrack pluginBridge test -type f \( -name "*.cpp" -or -name "*.h" -or -name "*.c" \) | xargs -n 1 --no-run-if-empty -I{} bash -c 'sed -i "/^\t* *\/\/--*$/d" {} ; sed -i "/^\t* *\/\/==*$/d" {} '
find README.md | xargs -n 1 --no-run-if-empty -I{} bash -c 'sed -i "/^\t* *\/\/--*$/d" {} ; sed -i "/^\t* *\/\/==*$/d" {} '
manx

manx

2017-09-24 07:25

administrator   ~0003240

r8950

Issue History

Date Modified Username Field Change
2016-07-31 06:59 manx New Issue
2016-07-31 07:00 manx Description Updated View Revisions
2016-07-31 07:02 manx Description Updated View Revisions
2017-03-26 13:45 manx Target Version => OpenMPT 1.?? (libopenmpt 1.0) (goals)
2017-08-22 12:05 manx Assigned To => manx
2017-08-22 12:05 manx Status new => assigned
2017-08-22 12:05 manx Note Added: 0003188
2017-08-22 12:10 manx Note Added: 0003189
2017-08-27 15:29 manx Target Version OpenMPT 1.?? (libopenmpt 1.0) (goals) => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)
2017-09-24 07:21 manx Note Added: 0003239
2017-09-24 07:25 manx Status assigned => resolved
2017-09-24 07:25 manx Resolution open => fixed
2017-09-24 07:25 manx Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)
2017-09-24 07:25 manx Note Added: 0003240