View Issue Details

IDProjectCategoryView StatusLast Update
0000832OpenMPT[All Projects] Playback Compatibilitypublic2016-07-21 12:25
ReporterBitRot2 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first) 
Target VersionOpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first)Fixed in VersionOpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first) 
Summary0000832: Sample corrupts after loading + portamento issue
Description

While loading this module (folknstorm.mod), samples are corrupted and makes strange noises.

On other module (getbrian.xm), the portamento command does not work as intended.
(Look for the pattern 2)
It's supposed to go higher than that, but it caps at some degree.

Steps To Reproduce
  1. Open the attached file in OpenMPT.
  2. Press play.
  3. Compare it to other players such as MilkyTracker, or listen to the MP3 file included (that's what it is supposed to sound like)
Additional Information

getbrian.xm used to play correctly in FB2K but caps when using modplay.

folknstorm.mod and its shorter version had some mixed results: In older version, the full version played well while shorter version was utterly garbled, and in newer version the shorter one plays fine but is corrupted in full version.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

BitRot2

BitRot2

2016-07-21 09:13

reporter  

PlaybackIssues.7z (208,652 bytes)
Saga Musix

Saga Musix

2016-07-21 12:04

administrator   ~0002516

folknstorm.mod contained ADPCM-compressed samples (which need to die already), those are now fixed in r6662.
You can download updated test builds from https://buildbot.openmpt.org/builds/ in about 1-2 hours.

In the case of getbrian.xm, I have to disappoint you. I guess you mean the portamento in pattern 2 on channel 13: It plays as intended (i.e. both like the OpenMPT version the tune was written in, and also like the original Fasttracker 2 would play it), and if FB2k does't cap the portamento, then it's simply wrong.

BitRot2

BitRot2

2016-07-21 12:16

reporter   ~0002517

ADPCM samples didn't quite play well on MODo (Android version of DUMB, so to say). I wonder why people used it.
Anyway, thanks!

I think the intention of using the portamento well above the limit of FT2 was a part of some sort of "note hack", probably benefiting from the bug in other players.

Saga Musix

Saga Musix

2016-07-21 12:24

administrator   ~0002518

ADPCM samples didn't quite play well on MODo (Android version of DUMB, so to say). I wonder why people used it.

To give a little bit of background story, ADPCM samples are not a MOD "standard" so to speak - they were first introduced in ModPlug Player in the late 90s to save space (back when it still mattered if you downloaded a 50kb or 100kb file), especially with the intention to use ADPCM-compressed modules together with the ModPlugin, which was a browser plugin that you could use to play modules on your website. In this case it was more important for the module to load fast than sound nice.
However, soon people started to (ab)use ModPlug Player to compress any module to save space, and unfortunately some of those modules also ended up being spread on the internet. Up until today, only few MOD players support ADPCM samples for this reason. Putting ADPCM-compressed samples into a MOD files is a gross hack, to say the least.

I think the intention of using the portamento well above the limit of FT2 was a part of some sort of "note hack", probably benefiting from the bug in other players.

I doubt it, since all major module players (especially around the time when the module was released) play the portamento like OpenMPT does - in fact, there is actually a much bigger bug in the arpeggios in that tune which is actually NOT played "as intended" by XMPlay for example, which is pretty much THE module player on Windows.
I'd just guess it's a plain oversight, or even intended to sound the way it sounds.

Issue History

Date Modified Username Field Change
2016-07-21 09:13 BitRot2 New Issue
2016-07-21 09:13 BitRot2 File Added: PlaybackIssues.7z
2016-07-21 09:19 BitRot2 Description Updated View Revisions
2016-07-21 12:04 Saga Musix Note Added: 0002516
2016-07-21 12:05 Saga Musix Assigned To => Saga Musix
2016-07-21 12:05 Saga Musix Status new => assigned
2016-07-21 12:05 Saga Musix Status assigned => feedback
2016-07-21 12:16 BitRot2 Note Added: 0002517
2016-07-21 12:16 BitRot2 Status feedback => assigned
2016-07-21 12:24 Saga Musix Note Added: 0002518
2016-07-21 12:25 Saga Musix Status assigned => resolved
2016-07-21 12:25 Saga Musix Resolution open => fixed
2016-07-21 12:25 Saga Musix Fixed in Version => OpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first)
2016-07-21 12:25 Saga Musix Target Version => OpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first)