View Issue Details

IDProjectCategoryView StatusLast Update
0000806OpenMPT[All Projects] User Interfacepublic2016-05-31 16:13
ReporterWodd Assigned ToSaga Musix  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.02.* (old testing) 
Target VersionOpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first)Fixed in VersionOpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first) 
Summary0000806: Incorrect Position
Description

When using the position jump extension, paying the pattern from start (F7) causes the module to jump to the incorrect position.

Steps To Reproduce
  1. Create a module with at least 257 patterns.
  2. Increase the row quantities of patterns 1 and 256 beyond 64.
  3. Place a position jump and parameter extension in pattern 256.
    At this point, you should have B01 with #00 in the row below.
  4. Place a pattern break in pattern 256. Break to any row from 64 to 1,024.
  5. Press F7.
    After that, you should notice that the module broke to the desired row (including rows 256 to 1,023). However, it jumps to position 1, not position 256.
TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-05-31 15:06

administrator   ~0002424

Bxx is position jump, not pattern break, so maybe that is your actual problem. Otherwise, please provide a compact file to demonstrate the problem, because I cannot see any issues here.

Wodd

Wodd

2016-05-31 15:28

reporter  

Incorrect Position.zip (1,142 bytes)
Wodd

Wodd

2016-05-31 15:30

reporter   ~0002425

I have uploaded a test file for you.

Saga Musix

Saga Musix

2016-05-31 15:34

administrator   ~0002426

I cannot spot any issues, i.e. it jumps to position 256, row 64.

Wodd

Wodd

2016-05-31 15:40

reporter   ~0002427

Hmm
It does that even using the replay pattern command (F7)?
I found that pressing Control+F6 works fine. But pressing F7 causes it to jump to the incorrect position.

Saga Musix

Saga Musix

2016-05-31 15:43

administrator   ~0002428

Please never mention shortcuts keys in bug reports again, only ever use shortcut names. F7 is a completely different play shortcut in my config so it was easy to miss this detail. Now I can reproduce it.

Wodd

Wodd

2016-05-31 15:52

reporter   ~0002429

I am sorry. I did consider difference in keyboard configuration later. I will do my best to remember this for future reports. Thank you for pointing out my error.

Saga Musix

Saga Musix

2016-05-31 16:12

administrator   ~0002430

Fixed in r6455.

Issue History

Date Modified Username Field Change
2016-05-31 14:59 Wodd New Issue
2016-05-31 15:06 Saga Musix Note Added: 0002424
2016-05-31 15:28 Wodd File Added: Incorrect Position.zip
2016-05-31 15:30 Wodd Note Added: 0002425
2016-05-31 15:34 Saga Musix Note Added: 0002426
2016-05-31 15:40 Wodd Note Added: 0002427
2016-05-31 15:43 Saga Musix Note Added: 0002428
2016-05-31 15:52 Wodd Note Added: 0002429
2016-05-31 16:12 Saga Musix Assigned To => Saga Musix
2016-05-31 16:12 Saga Musix Status new => assigned
2016-05-31 16:12 Saga Musix Note Added: 0002430
2016-05-31 16:12 Saga Musix Status assigned => resolved
2016-05-31 16:12 Saga Musix Fixed in Version => OpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first)
2016-05-31 16:12 Saga Musix Resolution open => fixed
2016-05-31 16:13 Saga Musix Target Version => OpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first)