View Issue Details

IDProjectCategoryView StatusLast Update
0000793OpenMPT[All Projects] Playback Compatibilitypublic2016-05-31 17:15
Reporterrandom12343 Assigned ToSaga Musix  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAllOSAllOS VersionAll
Product VersionOpenMPT 1.26.00.* (old testing) 
Target VersionOpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first)Fixed in VersionOpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first) 
Summary0000793: MT2 support really needs some work
Description

Try those modules and check yourselves. All are, or were in the past, before servers were taken offline, freely available, even the one included in (the mentioned in filename) commercially available CD album.

http://www57.zippyshare.com/v/z7yExSen/file.html

Have fun attempting to fix playback on those.

For comparison there's also an XM version of one module included, which plays surprisingly good.

Steps To Reproduce

Unzip archive, select and play module.

Additional Information

File uploaded gets deleted in 30 days.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

random12343

random12343

2016-05-14 17:25

reporter   ~0002375

I know that the file size of the upload is large... It contains 4 modules though, 2 having copyright and thus can't be modified (even though the composer kindly shared them) and 2 being the same track on different formats, for comparison.

Saga Musix

Saga Musix

2016-05-17 19:27

administrator   ~0002377

The main issue I see with Dream Alone is that some instruments are not loaded correctly. I figured out how to make them load properly but I'm not sure if the fix is necessarily <i>correct</i> (time will tell).
As for the other tracks, it would be great if you could actually point out what is broken because I don't have time or patience to go through every module out there and figure out what's wrong.

MadTracker DSPs will not be supported until Yannick releases their code (which he intends to do), please do not open bug reports about those.

Saga Musix

Saga Musix

2016-05-17 19:32

administrator   ~0002378

r6372 (available within the next few hours from https://buildbot.openmpt.org/builds/) fixes everything in Dream Alone that I could identify to be broken. If anything else is still broken in that track (except for the lack of DSP support as I said), please let me know.

random12343

random12343

2016-05-18 08:26

reporter   ~0002382

Last edited: 2016-05-18 09:07

View 3 revisions

Not on PC at the moment so no way to check on madtracker.

Chaostar's tracks are on YouTube. You can check them there. I do recall them using dsp effects, although it's been a long time since I last checked.
They do some more simple stuff, (like on-the-fly BPM change) that do not seem to be supported though.

Saga Musix

Saga Musix

2016-05-18 12:12

administrator   ~0002383

That is my point - <strong>You</strong> are the one who knows what's wrong with the tracks, so please tell me which patterns / instruments / etc. are affected and don't make me sit through comparing minute-long recordings to find tiny details that sound different.

random12343

random12343

2016-05-18 12:36

reporter   ~0002384

Now you are asking too much. I don't even run Windows nowadays. It's all through libopenmpt, mp3s, and from memory.

Saga Musix

Saga Musix

2016-05-18 12:38

administrator   ~0002385

No, asking you for help to get your bug report fixed is not too much. MT2 should work just fine on Wine.

random12343

random12343

2016-05-18 12:44

reporter   ~0002386

Wine doesn't work on Android.

Saga Musix

Saga Musix

2016-05-18 12:54

administrator   ~0002387

Surely you have a PC somewhere to test it on? I'm not asking for providing this information right now, but if you don't provide it at all, don't get your hopes high that I find the time and willingnesss to listen through these modules to find bugs.

random12343

random12343

2016-05-18 13:11

reporter   ~0002388

Broken gpu. Only person around still having a computer (everyone else is into smartphones and tablets). It will take a while.

What you're asking is not a mere bug report. You want a beta tester. I just came here to submit a report, not to setup a testing system and start documenting what, where and when is wrong. I mean, even if I had a working system, that'd be in the beta testing boundaries.

Saga Musix

Saga Musix

2016-05-18 13:14

administrator   ~0002389

No, beta testing means that you test a beta version of the software. What I am asking you to do is not just throw random modules at me, but listen to them both in their original tracker and the current stable version of OpenMPT and list the differences. This is a completely normal process - bugfixing is always a collaboration between the reporter and the developer. As said, if you think this is too much, then don't expect the report to get any attention.

random12343

random12343

2016-05-18 13:35

reporter   ~0002391

Admit it, you're just so demotivated that those modules sound bad for about 6 minutes out of their total 9 minutes, that you find excuses so that you won't fix all the problems they have.

I mean, you do stay here arguing while you could have just listened to them all already, on both madtracker and openmpt, while I lack a working system to. :p

Saga Musix

Saga Musix

2016-05-18 13:37

administrator   ~0002392

Yes, I lack motivation to listen to playback details for 10 minutes. That is perfectly normal. You are the least cooperative bug reporter I have probably ever had to deal with. You are probably not aware of it but OpenMPT is about more than just your bug report and there are 1000 better things to do to improve the software than trying to guess which part of a module sounds wrong.

random12343

random12343

2016-05-18 13:56

reporter   ~0002393

Fine. Don't fix those issues. Let them be... forever.

random12343

random12343

2016-05-18 13:58

reporter   ~0002394

Also, all 4 tracks are shorter than 9 minutes.

Saga Musix

Saga Musix

2016-05-21 17:42

administrator   ~0002407

The playback improvements accumulated over the last half year should hopefully play those tracks in a more acceptable way in libopenmpt 0.2.6401-beta17. If they don't, point out what's wrong.

random12343

random12343

2016-05-21 20:31

reporter   ~0002408

Last edited: 2016-05-21 20:47

View 2 revisions

For starters, the tempo handler is wrong. Yes, Power of Light is fixed. Other songs however (that I have no permission to share) seem to slow down instead of speeding up. They would stay at constant speed even when supposed to change speed before the Power of Light fix. Now the speed decreases instead of increasing.

Also, the voice samples on Dream Alone seem to be missing some settings. The fixed samples, that would not play before, sound different than the samples that always played. They should all behave the same.

random12343

random12343

2016-05-21 20:45

reporter   ~0002409

Some good news, the newly supported imported commands and effects impoved like a dozen modules I have around... the kind of modules I can't share unfortunately.

random12343

random12343

2016-05-21 22:51

reporter   ~0002410

OK. After further inspection it seems that for some reason, modules messing with tempo now report double their original playtime.

The modules that I have locally that play slow actually play at exactly half their intended speed, doubling their playtime.

The ones from Chaostar that I uploaded, Power of Light and Haunted Heart play at their intended speed... twice in a row.

Saga Musix

Saga Musix

2016-05-21 22:58

administrator   ~0002411

<blockquote>Also, the voice samples on Dream Alone seem to be missing some settings. The fixed samples, that would not play before, sound different than the samples that always played. They should all behave the same.</blockquote>
The only difference I can spot is the missing flanger effect - but as said, MadTracker DSPs cannot be implemented until Yannick hands over the source.
If you are referring to the differences in loudness between the various vocal samples - I verified that they also have differing volume in MT2.

<blockquote>After further inspection it seems that for some reason, modules messing with tempo now report double their original playtime.</blockquote>
Oops, that bug is entirely unrelated to MT2 but lies somewhere in the tick calculation for modern tempo mode. It should be gone when re-calculating the length after playback started, but of course this will be fixed.

<blockquote>The modules that I have locally that play slow actually play at exactly half their intended speed, doubling their playtime.
</blockquote>
MT2's tempo mode is rather different from OpenMPT's so I fear it might be next to impossible to fix it for all modules out there. If you could upload one of those problematic tracks, that would be helpful. If you cannot spread them, you may check the "private" box below the comment field so that only developers can see the link to the module.

Saga Musix

Saga Musix

2016-05-21 23:07

administrator   ~0002412

Okay, r6407 fixes the incorrectly reported playtime.

random12343

random12343

2016-05-21 23:10

reporter   ~0002413

Last edited: 2016-05-21 23:20

View 2 revisions

Great. No need to risk copyright infringement. Will update with the results after checking r6407.

random12343

random12343

2016-05-22 11:10

reporter   ~0002415

Last edited: 2016-05-22 15:00

View 3 revisions

Yeah, some modules still play at wrong speed.

Check the module below, just do NOT share.

removed

Saga Musix

Saga Musix

2016-05-22 13:44

administrator   ~0002416

Thanks, I got the file. I guess this one could somehow be fixed, it misses the "BPM+" chunk which I so far assumed would be present in every module that uses modern tempo mode, but apparently it is not required. Let's see how that can be fixed.

random12343

random12343

2016-05-22 15:31

reporter   ~0002417

You've got this. Looking at your code gives that away.

The only limitation is the amount of time you're willing to spend.

Madtracker is arguably the most advanced oldschool tracker currently out there and it's more than 15 years old. About time it gets superseded by something more recent, more compatible, with more decent code base.

openMPT more or less has what it takes. Only real hold back is the lack of dsp and vst... and that is a pity.

Saga Musix

Saga Musix

2016-05-22 15:42

administrator   ~0002418

<blockquote>Only real hold back is the lack of dsp and vst... and that is a pity. </blockquote>
It has VST support, but obviously only on Windows.

<blockquote>The only limitation is the amount of time you're willing to spend.
</blockquote>Not only, it's more the willingness to introduce huge changes to the code which will benefit only a single format that is not even the key of focus of the tracker. OpenMPT can do most of the things that are still missing or broken in the MT2 import, but it does them slightly differently than MT2 does. Not in a better way, not in a worse way, just different. Hence if I wanted to support all those MT2 idiosyncrasies, I would have to introduce heavy architectural changes to the program which would remain untested most of the time because they only become visible when dealing with MT2 files.

Anyway, as said, I'll look into it, but it requires quite a few workaround so I don't know how that will pan out ultimately.

random12343

random12343

2016-05-22 16:12

reporter   ~0002419

My point is that openMPT is slightly falling short.

If the import works relatively well, you have an easier time editing projects started on madtracker. No need to emulate the playback behavior perfectly on the imported modules when you can do small edits to achieve the same result.

The limitation is the missing features stopping you from achieving the same results and the need to heavily edit a module after importing to get the same results.

Saga Musix

Saga Musix

2016-05-24 22:09

administrator   ~0002420

r6421 should hopefully get the tempo right in a few more tracks (and not break it in others) including the one you posted.

random12343

random12343

2016-05-24 23:48

reporter   ~0002421

We"ll see...

random12343

random12343

2016-05-26 19:30

reporter   ~0002422

Yeah, much better now. There are still some problems but from what I can tell these are due to missing dsp support.

Saga Musix

Saga Musix

2016-05-31 17:15

administrator   ~0002432

I'll close this issue then since I cannot do anything about it until Yannick gives me the DSP code anyway. If any further issues arise, feel free to reopen this issue or open a new one.

Issue History

Date Modified Username Field Change
2016-05-14 15:38 random12343 New Issue
2016-05-14 17:25 random12343 Note Added: 0002375
2016-05-17 19:27 Saga Musix Note Added: 0002377
2016-05-17 19:28 Saga Musix Assigned To => Saga Musix
2016-05-17 19:28 Saga Musix Status new => assigned
2016-05-17 19:32 Saga Musix Note Added: 0002378
2016-05-18 08:26 random12343 Note Added: 0002382
2016-05-18 08:50 random12343 Note Edited: 0002382 View Revisions
2016-05-18 09:07 random12343 Note Edited: 0002382 View Revisions
2016-05-18 12:12 Saga Musix Note Added: 0002383
2016-05-18 12:36 random12343 Note Added: 0002384
2016-05-18 12:38 Saga Musix Note Added: 0002385
2016-05-18 12:44 random12343 Note Added: 0002386
2016-05-18 12:54 Saga Musix Note Added: 0002387
2016-05-18 13:11 random12343 Note Added: 0002388
2016-05-18 13:14 Saga Musix Note Added: 0002389
2016-05-18 13:35 random12343 Note Added: 0002391
2016-05-18 13:37 Saga Musix Note Added: 0002392
2016-05-18 13:56 random12343 Note Added: 0002393
2016-05-18 13:58 random12343 Note Added: 0002394
2016-05-21 17:42 Saga Musix Note Added: 0002407
2016-05-21 17:43 Saga Musix Status assigned => feedback
2016-05-21 20:31 random12343 Note Added: 0002408
2016-05-21 20:31 random12343 Status feedback => assigned
2016-05-21 20:45 random12343 Note Added: 0002409
2016-05-21 20:47 random12343 Note Edited: 0002408 View Revisions
2016-05-21 22:51 random12343 Note Added: 0002410
2016-05-21 22:58 Saga Musix Note Added: 0002411
2016-05-21 23:07 Saga Musix Note Added: 0002412
2016-05-21 23:10 random12343 Note Added: 0002413
2016-05-21 23:20 random12343 Note Edited: 0002413 View Revisions
2016-05-22 11:10 random12343 Note Added: 0002415
2016-05-22 11:11 random12343 Note View State: 0002415: private
2016-05-22 11:11 random12343 Note Edited: 0002415 View Revisions
2016-05-22 13:44 Saga Musix Note Added: 0002416
2016-05-22 15:00 random12343 Note Edited: 0002415 View Revisions
2016-05-22 15:00 random12343 Note View State: 0002415: public
2016-05-22 15:31 random12343 Note Added: 0002417
2016-05-22 15:42 Saga Musix Note Added: 0002418
2016-05-22 16:12 random12343 Note Added: 0002419
2016-05-24 22:09 Saga Musix Note Added: 0002420
2016-05-24 23:48 random12343 Note Added: 0002421
2016-05-26 19:30 random12343 Note Added: 0002422
2016-05-31 17:15 Saga Musix Note Added: 0002432
2016-05-31 17:15 Saga Musix Status assigned => resolved
2016-05-31 17:15 Saga Musix Resolution open => fixed
2016-05-31 17:15 Saga Musix Fixed in Version => OpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first)
2016-05-31 17:15 Saga Musix Target Version => OpenMPT 1.26.03.00 / libopenmpt 0.2-beta18 (upgrade first)