View Issue Details

IDProjectCategoryView StatusLast Update
0001795OpenMPTUser Interfacepublic2024-06-28 22:28
Reportera11cf0 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version11
Product VersionOpenMPT 1.31.08.00 / libopenmpt 0.7.8 (current stable) 
Target VersionOpenMPT 1.31.09.00 / libopenmpt 0.7.9 (upcoming stable)Fixed in VersionOpenMPT 1.31.09.00 / libopenmpt 0.7.9 (upcoming stable) 
Summary0001795: Keyboard focus issues when switching from and back to OpenMPT in some cases
Description

after focusing anything in the upper half of any view (e.g. sample or instrument editor), switching to another application and then going back, the focus lands on a strange container object that doesn't seem to do anything.
Additionally, when switching from an OPL instrument to a regular sample with Ctrl+Up/Ctrl+Down, the focus remains inside the OPL editor. In this case it's really possible to modify the already hidden OPL instrument.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2024-06-28 20:06

administrator   ~0005982

The OPL editor issues is fixed in r21095. The other issue will require a bit more investigation as I'm not entirely sure why the focus doesn't stay on whatever item was last focussed.

Saga Musix

Saga Musix

2024-06-28 21:19

administrator   ~0005983

I found one half-baked solution so far for the other issue, but that would always set the focus to the first item of the dialog, not the last-focussed one. Not really optimal, especially since on various views this will be a toolbar button and not an input field.

Saga Musix

Saga Musix

2024-06-28 22:27

administrator   ~0005984

I found a better solution in r21097.

Issue History

Date Modified Username Field Change
2024-06-28 19:35 a11cf0 New Issue
2024-06-28 20:06 Saga Musix Assigned To => Saga Musix
2024-06-28 20:06 Saga Musix Status new => assigned
2024-06-28 20:06 Saga Musix Note Added: 0005982
2024-06-28 21:19 Saga Musix Note Added: 0005983
2024-06-28 22:27 Saga Musix Note Added: 0005984
2024-06-28 22:28 Saga Musix Status assigned => resolved
2024-06-28 22:28 Saga Musix Resolution open => fixed
2024-06-28 22:28 Saga Musix Fixed in Version => OpenMPT 1.31.09.00 / libopenmpt 0.7.9 (upcoming stable)
2024-06-28 22:28 Saga Musix Target Version => OpenMPT 1.31.09.00 / libopenmpt 0.7.9 (upcoming stable)